Glasswire can't connect to local server

after pc format I installed glasswire, and when i run it, i see only “connecting to local server”. After 1 minute, i see statement “The Glasswire service stopped running”. What can i do?


Please go to add/remove programs and uninstall GlassWire. Please don’t use a third party installer to uninstall, because it will leave our driver and cause this problem to continue.


Download GlassWire from and check the box in the installer “clean install” and let me know your results.

unfortunately it did not help, but i when install Glasswire, I saw in install log “Glasswire service cant start because other service is stopped”

I had the same problem starting with Ver 2.0.78. Ver 1x worked flawlessly since I purchased the license Apr2017. After reading Remarks in related Topics, it seemed that Services was where the issue might be. I then found the Dependencies for GW’s service namely Base Filtering Engine & WLAN AutoConfig. The Base Filtering Eng was Running, but the WLAN AutoConfig was not. After Manually Starting the WLAN AutoConfig (Svc), Glasswire immediately started running.

My question to Support is: Now that I changed the WLAN AutoConfig service to “Auto-Start”, will that effect anything else on my pc? I’m using an HP Z820 desktop, running Win7 64. There is no Wireless Adapter in this pc which seems to be the focus for the WLAN service.

1 Like


We have put out a fix for this problem. Please try 2.0.105.

Please let me know your results.

Hey Ken,
Thanks for the quick response. This morning I installed 2.0.105. Except it couldn’t “connect to the server” again. Went into Services and Manually started WLAN Auto&Config. This time Glasswire DIDN’T run. Don’t know what happened, but I ended up Uninstalling Glasswire, rebooting, removing the “ProgramData” & “AppData” Glasswire folders as you mentioned in other threads. Then doing a “Fresh” install of 2.0.105, as you also mentioned.

This time Glasswire started (same as before) trying to connect to the server. After starting the WLAN AutoConfig service again, Glasswire took off running, Yea.

Hoping this solves the problem.
Regards, John

1 Like


I have shared this info with our team, thanks.

@Ken_GlassWire - This topic should be revived, as its still valid on version 2.0.123. I didnt have any problems installing on my Win10 machine, nor a Win7 machine, but I installed on a 2nd Win7 machine which never had WiFi capabilities before, so its WLAN Auto Config svc was disabled, since it was never necessary to have running. I tend to run my systems very lean and remove anything that isnt required per each machine. The system has been running stable for months and months with TinyWall, but seriously considering a switch over of all PCs to GlassWire. I concur with @junkkeys that the issue is not resolved in any new version of this program, as I just recently (within past 2 days) downloaded the GW installer (which was used on the working CPUs) and yet it still failed because the WLAN Auto Config service was disabled on the problematic Win7 machine. Once I changed the service to to ‘Manual’, this resolved my issue of connecting to the Local Server within GlassWire and all was well. Maybe in the next release the program can verify that this service is running/not disabled?

Hi, i dont knoe=w if it is my server but after installing v2.1 it still have the same problem.


What OS version do you use? Sorry for the issue.

Not sure if this is still a recurring issue although I got the same problem, after I restarted my PC it started up glasswire per usual but now glasswire is just dead.

Here’s some screenshots:

This error appears after I’ve had 3 attempts at connecting to the local server. I’ve tried reinstalling, restarting my system, clicking the “Restart Glasswire” button (it shows the windows security warning but doesn’t do anything if allowed) and constantly tried reconnecting. I’m running this on windows 10, its the first time this started happening


Please try uninstalling in add/remove programs (don’t use a third party uninstaller).

Now reboot - very important!

Now reinstall our latest software using our “clean install” option. Is it working now?

Try checking your services. If you are running windows press the windows key and type,


Press Enter.

When the Services window opens up press the “G” button on your keyboard. Scroll down until you see the “Glasswire Control Service”.

Right click it and then click properties. After that, another dialog box will open. Look for where it says, “Startup Type”. Make sure this is set to Automatic. Also, check for where it says “Service Status:” Next to that it should say “Running”. If it doesn’t say running, then right below that click on the “Start” button.

After it starts, click “OK”. When this is done, open up Glasswire and click the connect button if necessary. If that doesn’t work then try the restart glasswire button.

The problem should be resolved. To confirm that this will be automated, reboot your computer. The problem should be resolved. Post back with your results and/or any questions you have.


I did about 4 clean installs, I’m not sure what I did right on the 4th but it finally worked, thanks for the advice, hopefully this doesn’t happen again.

1 Like

I’m glad it’s working now. Sorry for the issue.

Got the same issue, installed on windows 10 pc, all fine. This was the 5th app i have tried liked it the most. Installed on windows 7 x86 laptop all fine. Installed on a windows 7 x64 gaming pc cant connect to server, sever stopped working.

I have uninstalled rebooted, reinstalled also reinstalled using delete all data box checked. Checked installer hash. Deleted app data (programdata) folder for glasswire. uninstalled av, turned off and on firewall, redone firewall, and base filter in services.msc, made sure the wlanauto service thing was running. disabled or uninstaller any ghost wifi cards or network adapters. Updated windows.

not sure why it wont work (seems to be not service installed), I could not find glasswire gw or any other glasswire like named service in the services.msc list. I found the post about making .bat file, to install the driver.

I also installed in admin mode, I gave all files admin privileges in the app folder. HELP plz.

I have seen this with Windows 7 users who have no Windows updates with a fresh Windows 7 install. If you are up to date with Windows GlassWire will then work. Not sure why…

Ok FIRST OFF! make sure your not in AIRPLANE MODE, if you are turn it off by typing airplane mode in your search bar, or by starting Glasswire Control Service which automatically did it for me which i will explain how to do. Hit the windows key+R on your keyboard to open the “run app” , type “services.msc” and hit enter. When a window opens find “WLAN AutoConfig” in the name list and right click it and click properties. Make sure startup type is set to manual by clicking the drop down button, also make sure service status shows running, if not click right underneath service status.

Once that is done hit OK to close that window and you should be back to your services windows, now find Glasswire Control Service then right click it and select properties. Now here make sure startup type is set to automatic and service status shows running, if not click start underneath it then it should startup also turning off airplane mode if you haven’t done so, then hit ok to close that box. Close the “services.msc” page then proceed to open or return to your glasswire application, then click connect if it has not done so already. Now glasswire should startup with no problems…hopefully. If you still are unable to connect feel free to email me at my gmail “Zomborg2425@gmail,com” replace comma with . in email and i will try my best to help. (disclaimer: I am no IT professional or anything like that but i know my way decently around a computer) thanks hope this helps

1 Like

This ended up working to fix my issue. Thanks!

1 Like