Glasswire continously using internet bandwidth

This started happening for a month or so. Whenever I install Glasswire, it starts to use the internet bandwidth fully and for no reason. When I open up the Firewall tab it shows no other application using the internet [even Glasswire itself] but it continuously uses my internet bandwidth. The same isn’t shown on any other internet monitoring software.

I understood that it’s Glasswire causing the problem when I un-installed it and everything was back to normal. I tried this for over 4 times installing and un-installing over the course of a month on my Windows 10 laptop.

And I also get a minidump file on the desktop GWCtlSrv.exe.3068 that becomes larger in time. Maybe taking a look at it can identify the cause of the problem. Probably that’s why my internet is being used. Please do.

Minidump file:


GlassWire doesn’t use bandwidth unless you’re monitoring another PC remotely. Some third party utilities that show bandwidth usage can see that data is exchanged between the service running on your PC and our user interface, but this is just data being exchanged on your PC and not over the network.

Once per day GlassWire checks for a software update, and also updates its malicious host list, but you can block GlassWire itself under its own Firewall if you prefer.

When running GlassWire what does it show is using your data there?

Can you tell me more about your network? Also, can you upgrade to our latest software and do a “clean” install with the installer and see if you generate any more dumps or not?

It’s funny because when I’m at my university dormitory this problem doesn’t happen. However when I’m using my Cisco modem at my home , it does. And the problem is with Glasswire itself, because uninstalling it solves the problem. I have also added a link to the minidump file that Glasswire continuously keeps writing onto which grows in size, so it definitely is the problem. Please take a look at it.

I did a clean-install various times over the course of 3 weeks, and yet the problem persists. Every time the minidump file is formed. The firewall doesn’t show that Glasswire is using the internet either.


Ah, you said Cisco. Now I know what it is.

With our previous version of GlassWire, GlassWire would do lookups to check your network for other devices. Some Cisco hardware would report this as an “ARP storm” so we updated our software to fix this. Please update.

You can also block the “network” tab from scanning at all if you read the report above.

Please upgrade and let me know your results.

I didn’t know a new version was there. Okay I’ll try. But I’ll have to get back home to test it out. Thanks

My glasswire control service is constantly using bandwidth to an external IP

i Dont use the control service, if I block it then the app deactivates itself after some time.


Did you upgrade to our latest version of GlassWire?

Yep upgraded yesterday.

Are you using a free version of GlassWire or a paid version? Is the network activity you show from the previous version of GlassWire or the current one?

You can disable our local network scanning functionality if you are using our paid software. Checking the local network for new devices uses some minimal network activity.

To disable Network auto-scanning completely create a text file called glasswire.conf and place it in the c:\programdata\glasswire\service folder. Add this string to the text file: enable_network_scan = false then restart the GlassWire service. We plan to add a setting for this in the future.

Are you aware is the OpenDNS resolver?

@LorenAmelang Good catch!

I tried updated to the latest version (88) and yet the problem still continues. The only way to stop using the bandwidth is to uninstall Glasswire. Isn’t the problem resolved yet?


Could you post a screenshot here of the latest version that shows this, or email it to us? Do you use OpenDNS Umbrella or OpenDNS name servers on your PC? If so are the name servers set up on your PC or router?