GlassWire Control Service will not start


No such service on a w2008 server with no wireless card :frowning:



Thanks for your report. We’ll continue to investigate this problem.


Hi there !

I encountered the same issue on my personnal PC. Had too activate the WlanSvc to get back GlassWire. As I’m on a wired connection, without any wireless adaptater, I want to deactivate this service.

I see in the 2.0.80 changelist “Removed the dependency for the wlanapi.dll for Windows Server customers”. Do you plan to reduce the dependency on the WlanSvc service for standard en pro Windows editions too ?

Thanks, and happy new year to all ! :champagne:


Any solution please. Remove the dependency or give us the old installer, both good solutions. More than 2 weeks since the issue was raised.


It makes sense that you would have this problem. I have noticed that this program is started before I go on line. There needs to be a full examination from my side, as to why I was receiving a blip at startup while my Internet is not auto start. I keep it off as I turn off the computer, so that it won’t be on when I start. So why I was getting a bump of data to the router is probably also why I have no way to start this service now. There is something hidden here and it is not clear what it is.

I just today broke down after months of prompting to download the new version, and the new version worked but then it was asking me to clear something or else upgrade, so I thought, why not just go back to the old version. So I tried that, and it will not start. I even did a system restore and 2nd download of another program I had also installed today.

I don’t know why I pushed the button on the Glasswire today, but I see in my windows firewall that all my Glasswire blocks are all still listed there.

I tried to clear the windows system can’t be started (service start 1067 error) by exporting then deleting the registry key, and running sfc /scannow in cmd. Then restarting and merging the exported entry for glasswire. This doesn’t work to get it started either.

However it makes some sense that there is something causing the thing to connect that is inside the router. Probably , I think it is the same something that the NSA or KGB or whoever are using to spy on all of us.

I may go to the new version again. I did that restore, so I am reluctant to move forward again, after that effort.

…30 minutes later: (edit)

I have installed it again, and once again all the firewall settings appear to be reset, Now that I reinstalled the new version they are once again deleted. (as I saw them after the restore in the Firewall).
All this leads me to wonder if there are things being whitelisted by the program. I don’t see any of the svchost items which I have come to expect. What gives? So the firewall shows NO red slash circle entries as before ( I exported the old firewall list prior to the most recent install). It includes all these entries from the old Glasswire. I suppose after a week or two if I don’t see these entries replaced by new versions then I will know if there is some whitelisting going on in the new version.

I did also notice with a look in the temp folder in appdata local, and found 3 logs from earlier and one new log from the try I did just before installing the new version which logs say (all four) found newer version can’t go back to old version.

These log files are from vcredist x86 and state:
[36B4:36B8][2018-01-03T21:40:24]i101: Detected package: WindowsVista_MSU_x86, state: Absent, cached: None
[36B4:36B8][2018-01-03T21:40:24]i101: Detected package: WindowsVista_MSU_x64, state: Absent, cached: None
[36B4:36B8][2018-01-03T21:40:24]i052: Condition ‘VersionNT >= v6.0 OR (VersionNT = v5.1 AND ServicePackLevel >= 2) OR (VersionNT = v5.2 AND ServicePackLevel >= 1)’ evaluates to true.
[36B4:36B8][2018-01-03T21:40:24]i199: Detect complete, result: 0x0
[36B4:36D8][2018-01-03T21:40:24]e000: Error 0x80070666: Cannot install a product when a newer version is installed.

basically the 3 logs from earlier and one more from this evening the logs show clearly that it is in fact talking about the installation attempts of the older downloads of glasswire.

All I want is to beable to have the same great program it has been for 10 months leading up to the mistake of installing today. Why is my firewall been deleted? I don’t understand why the reset.


This is true, I forget to mention about the firewall reset… that wasn’t funny at all. Pretty please, provide a link with the old version of the software.


not only is it a firewall reset, the new version isnt showing as many ips connecting. IDK if it is the particular Chrome dev from local only that was updated automatically in December, because recently having no issues with malware or bad click action, I had not been looking at glasswire in the new dev Chrome. but the old glasswire As I Remember, had from 2 to 15 ip address hosts for every second of Chrome use.

anyone seeing this? whats more consistent with this being a glasswire fault is that I was livestreaming with glasswire 2.0 today and NO PINK DATA PLATEAU. every time I livestreamed in 1.2 I would get the pink steppe of pink upload data. Now nothing. So it seems that Glasswire is become ineffective.



We haven’t changed anything with how the host reporting works. When you say pink, how do you mean? The shapes of the graph can change depending on how large/small you drag the GlassWire window, could it be that?