GlassWire Control Service will not start


#1

I just bought GlassWire Pro. I downloaded and installed it. I was given a serial number and the instructions said go to the GlassWire button in the upper left corner and select “Activate”. There is no “Activate” option displayed. Also when it try’s to connect it fails. When I try to start the service I get "Windows could not start the GlassWire Control Service on local computer. Error 1075: The dependency service does not exist or has been marked for deletion.

The software sounds really good, so has anyone run into this issue on Windows 7?


#2

Sorry for the problem. Could you try uninstalling GlassWire completely, then going to the ProgramData folder and deleting the “GlassWire” folder there, then rebooting?

Next please download our latest software at https://www.glasswire.com/download/ and install it.

After that please go to the top left GlassWire menu and click it where it has a down arrow, then you’ll see where it says “Activate” then you can paste in the code. Please let me know if this doesn’t solve the problem.

Thanks for upgrading and I apologize for this problem.


#3

Also, please see this image of the Activation menu.


#4

You could try registry entry -regedit=HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp–right click on =DependOnService-click- delete-- this cured it for 51 posters on a Windows website .You will get a long winded answer from MS involving maybe re-installation or any point in between that cured it for 3 people. Your choice.


#5

I followed the steps above, uninstalling reinstalling and rebooting. I get the same result. The puzzling part is the drop down displays a different list of options.

If I try to just start the GlassWire Control Service, I get: Oops, new users are only allowed one image, so the error dialog that comes up says:

Windows cannot start the GlassWire Control Service. Error 1075: The dependency service does not exist or is marked for deletion."

I know I must be overlooking something simple.


#6

Very weird. You did a total uninstall uninstall, then deleted the GlassWire folder in “ProgramData” and rebooted and it’s still acting this way? I have never seen anything like this before. Let me discuss this with our dev team.

For now could you try one more uninstall/reinstall?


#7

I tried again with a total uninstall, deleteing of the ProgramData folder and rebooted. Still the same results. I don’t know why the Activate option would not show in the GlassWire button. It’s like I am not getting the right version. I can try to install on one of my other computers just to see what happens. This is very disappointing. :frowning:


#8

We have a 30 day refund policy so if we can’t get GlassWire working for you we’ll refund you in full. Let me see if our dev team has some ideas on how this is possible. Thanks for reporting this.


#9

We discussed this problem in detail and it appears that you should try opening services and set the Base Filtering Engine service’s startup type to Automatic and launch the service. After that
you should be able to start the GlassWire service.

Open Task Manager by right-clicking the taskbar and then clicking Task Manager. Click the Services tab to see the services that are currently running under your user account.


"Connecting to the local server"..fails
#10

Last night I tried installing on my laptop running Windows 7. GlassWire installed perfectly. I then tried the install on my wife’s laptop running Windows 10. GlassWire also installed with no problems. This morning I tried again on my desktop to no avail. I then went to the forum and I saw the post on the Basic Filtering Engine service. I looked at my services and there was no Basic Filtering Engine service! I went to Google and found how to restore the service and also found out that it could have been malware that deleted the service through a vulnerability in the Flash player. Once the service was restored, GlassWire started working immediately! Your development team was right on the money! Please thank them for me. Glasswire is giving me the info I was looking for, now I have to find out how to use all the other capabilities. However, first I am off to get the latest update to the Adobe Flash player!

Thanks again for all your help.


#11

Great! If you think you may have malware it might be best to reinstall Windows on that PC. Also instead of installing Flash use Google Chrome as your browser instead which already supports Flash without having to install it on your PC.
https://blog.glasswire.com/2015/02/05/living-without-adobe-flash/


#12

I followed the steps above but still not working on w2008 server R2.
Can I have a link to the old version please?


#13

@Andrei_Hetel

Please try this update: https://www.glasswire.com/download/


#14

@Ken_GlassWire

I can see there link only to the latest version - which doesn’t work for me.
I would love to come back to previous version that worked like a charm.


#15

@Andrei_Hetel

The latest version was released a few hours ago so you probably have not tried it yet. I apologize if I’m mistaken.


#16

Hi,

Tried latest version too. Still cannot start GlassWire Service. Error is:
The GlassWire Control Service service depends the following service: WlanSvc. This service might not be installed.
This is a win 2008 Server R2 with no wireless.
My question again: can I have a link to 1.2 version? That one worked perfectly.


#17

@Andrei_Hetel

If you run Windows update on that server does it solve it? Are you a paid or free user? I’ll report this to the team, thanks.


#18

@Ken_GlassWire

All windows updates are installed. Paid version.
Thank you.


#19

@Andrei_Hetel

I emailed you.


#20

@Andrei_Hetel

Could you try this for us? We can then solve this.

  1. Make a screenshot of the About window of GlassWire.
  2. Push Win+r and in Run window type services.msc + Enter;
  3. Find GlassWire Control Service at the services window and double click it;
  4. Make a screenshot of the Dependencies tab:
  5. Find the WLAN AutoConfig service at the services window and start it if it’s not running.

You can also make it auto start in the settings:

34338865-e810910c-e97d-11e7-9b22-26e770b6451c