GlassWire Crashing when loading firewall

I have a Samsung galaxy S6. I can open glasswire, change the theme, (I have premium version) but when I open the firewall menu it loads the options for about 15 seconds and eventually crashes. I have tried restarting, uninstalling and reinstalling, uninstalling then restarting and then installing. I even tried uninstalling other vpn apps, but nothing seems to work. I am unsure what to do. Thanks


I have seen other Samsung users with a similar issue. It was a bug with Samsung’s VPN implementation in those cases and updating the phone’s software solved it. Could this be the issue with your phone?

Also if it still does not work please email the email address on our Google Play page, thanks.

Alright, If you mean by just doing a regular software update, my phone no longer receives those. I did check though, and there isn’t one. I’ll send you guys an email, Thanks!

We will have a major Android update out in the next couple of months. Please give it a try when it comes out and let us know your results.