GlassWire Disconnects Sparodically

Yeah, I considered Webroot may be doing so, but I’ve tried disabling Webroot as well, only after glasswire stops logging. I suppose its possible that the monitoring process was killed in an unusual way and couldn’t properly recover… I’ll give it a go disabling webroot before boot.

Do you happen to remember what software the other client was using?

Well, completely disabled anti-virus and still couldn’t get GlassWire to connect. Where can I download the beta version?

The software was proprietary if I remember correctly.

How much memory does your PC have? Do you run Bittorrent often? Are you sure there are no dmp files on your desktop?

We have no beta version, but our latest desktop software is available at Sorry for any confusion.

I’ve installing Webroot SecureAnywhere trial version - I regularly change antivirus so it’s no problem to do so - so I might be able to see if it is causing the problem. This sort of problem happens very few people so I may have no success reproducing it.

Did you have the GlassWire problem before you updated to this version of Windows? If so, then I could test on my Windows Pro computer which is on Version 10.0.14393 (1607).

In the meantime, I’ll try the Webroot SecureAnywhere trial on Windows Home Version 10.0.15063.

I don’t torrent anything, I have 32gb of ram, and I’m certain I don’t have any dmp files on my desktop.

I’m not sure, I did have GlassWireinstalled before updating, but I didn’t use it much until I bought it for the mini display. However I didn’t ever notice it when I first started using GlassWire.

Webroot SecureAnywhere (WSA) can interact with the Windows Firewall and can terminate the GlassWire processes so it will be interesting to see if any problems develop for me.

  • WSA front ends the Windows Firewall so it is a potential conflict with GlassWire. WSA says that it handles outbound connections which is what GlassWire also does.
    So far, WSA’s pop-up windows for 'Warn if any process connects to the Internet unless specifically allowedappears GlassWire'sAsk To Connect` notification.
    • WSA | PC Security | Firewall
    • WSA | Advanced Settings | Firewall / Web Shield
  • WSA can control running processes including GlassWire’s processes.
    • WSA | Utilities | System Control | Control Active Processes`

Hm, interesting, I wonder if any of those stay active after shutting it down… Let me know what you find out, I’ll tinker some more with it. Although my active process control looks like this

Good to see there is no GlassWire process being blocked on your system.

I have found no problem with WSA. Nor have I reproduced your problem. I think it is unlikely that I will because, even if WSA is related to the problem, it affects so few people that I may not be able to reproduce it.

As for WSA, it’s working fine. It seems light-handed in interacting with Windows and other applications. My memory of Webroot AV is a little hazy, having not tried it since last decade. But it does appears to be a much better product. Like automatically monitoring software that it is not familiar with, e.g. wscc.exe:

Comparing the firewall feature it with GlassWire, I don’t like that the WSA firewall setting didn’t appear to show any change in the Windows Firewall. I much prefer that any changes made using GlassWire’s Firewall tab show up in the Windows Firewall rules and settings; I can immediately see whether features are working correctly.

Yeah, I really like Webroot, for the most part it behaves smart and intuitively. I also like how light it is in it’s resource use. I guess my next step, I’ll try to boot into safe mode and run Glasswire from there.

1 Like

After a day, the problem has not appeared.

WSA and GlassWire are clearly interacting at the Firewall with “Ask To Connect” working sometimes and WSA working the other times.

1 Like

Now I have a definite problem interaction between WSA and GlassWire which looks like it relates to this topic.

GlassWire Ask To Connect notifications weren’t happening most of the time so I turned WSA firewall blocking off:

  1. Go to WSA | Advanced Settings | Firewall / Web Shield
  • Select Allow all processes to connect to the Internet unless explicitly blocked which is the default setting.

Some time later - as much as 75 minutes later so it may not be related - GlassWire momentarily, for less than a minute, lost connection on the Usage tab.

Immediately after this I received all four GlassWire Firewall Ask To Connect notifications that I had not received since I changed the WSA setting:

  • two for new applications (Vivaldi and MX5 web browsers) I’d since uninstalled
  • one for CCleaner which I’d used to uninstall the applications.
  • one for Skype which I’d run to test the camera in relation to another issue in GlassWire

@CoreParadox, my problem may be different than your problem because:

  • the reconnection happened almost immediately…
    Do you ever get such a short disconnection?

  • … so I didn’t have to reboot.
    Do you have to reboot every time?

  • it may relate to restoring the default Firewall setting in WSA.
    Have you changed that WSA | Advanced Settings | Firewall / Web Shieldsetting from the default?

Well, I installed some upgraded parts in my PC today, and the issue has yet to appear in about 6 hours of use, I’m wondering if reconnecting the Ethernet cable after plugging everything back in somehow resolved it… I’ll report back soon with an update.

1 Like

Hi @CoreParadox Core did you know that you can have Webroot monitor Glasswire app by entering the name under Identity Protection > Application Protection tab> on the right hand bottom click on add application ?

1 Like

Yup, I had whitelisted it there too. But luckily after installing these new components and re-imaging windows, I have not had this issue resurface.

1 Like

@CoreParadox good news! Thanks. :relaxed:

Excellent. WSA is causing me no problems now that it is not controlling any blocking. I’ll run WSA until the trial expires.

1 Like

I keep getting “internet connection lost”. Why is this happening?

Some of us users get a lot of “Internet connection was lost” alerts for no obvious reason apart from known causes like our computer going to sleep or hibernating or our network adapter being put into power-saving mode.

@Ken_GlassWire, I haven’t been able to work out what is causing the unexplained alerts on my network but I am planning to swap in other routers and see what happens in each case.

We have the Internet Connection Lost alert disabled by default because many PCs disconnect from the network while sleeping, or while idle. To see this alert you would have had to turn it on, and if you find it annoying you can go to settings/security and click “Internet access monitor” to disable it.

This alert can be useful for desktop PCs that don’t sleep on ethernet but it can be annoying for notebooks.