Glasswire doesn't work in Windows 8.1?


#1

So, I just downloaded Glasswire and installed it. Unfortunately even after restarting my computer, Glasswire just doesn’t work. The main window just won’t open. I can’t find anything that could tell me what might be wrong.

Windows 8.1, 64-bit
Windows Firewall


#2

@EmilyLyn,

So far I haven’t seen this issue. I use Windows 8.1 also. Could you try uninstalling GlassWire completely, rebooting, then reinstalling and see if that helps? If it does not help could you please send us any GlassWire logs that might be located in C:\Windows\Minidump?

Our “bugs” email address is here: https://www.glasswire.com/contact/

Thank you for reporting this problem so we can fix it.


#3

I’ve already tried fully reinstalling to no success, and C:\Windows\Minidump doesn’t seem to exist on my system.


#4

Found the problem. Apparently a version of Qt I had installed was the culprit. I uninstalled Qt and GlassWire began working.

It was also probably an outdated version since I haven’t worked with Qt in some time.


#5

Having the same issue, brand new install of windows 8.1 fully patched won’t work, service won’t start?

Uanble to attach a link or picture as I am new.


#6

Please try the following and let me know your results:

Open the Services tab at the Task manager and stop the GlassWire service (the status should become Stopped);

If the service is not stopping, you should terminate the process GWCtlSrv.exe;

Rename C:\ProgramData\GlassWire\service folder;

Uninstall GlassWire via the uninstall.exe;

Reboot;

Install GW.


#7

Many thanks, not sure what happen on the first install. However there was no service, hence it wouldn’t start.
Re installed and all working fine :slight_smile:


#8

Apologies (if needed) for resurrecting an old thread, but this is my very problem. I know, using Win8.1 in 2018?! Its what was on the laptop when I inherited it, what can I say?

Attempted install (and run following failed install) produces two error messages, both for missing files. “api-ms-win-crt-runtime-l1-1-0.dll” and the Qt5~ mentioned in other threads. There was an error that popped up once regarding missing MSVCP140.dll, but I can’t seem to get it to recur. How would I diagnose/find what Qt I have and replace it with the correct version? I’ve hunted down stray MSVCP’s before, that I can do., but what about that api?


#9

@xheralt

If you run Windows update, does it make any difference? Thanks.


#10

I will let you know when I can. My home internet is out and I’m on a different machine right now. I’ve discovered that Libre Office 6 (the current version) also depends on that same Microsoft api, so that’s two unusable programs I have currently o_O


#11

This laptop was out of circulation for a while; 132 Windows updates currently installing.


#12

this is a helpful discussion. I also face the same problem.


#13

Please make sure you’re using our latest software, the problem should be fixed. Thanks.


#14

I also agree with @john_parker its really helpful discussion