Glasswire fails to install

Glasswire works well on my laptop. However, on my desktop the Glasswire service has been stopping. I just unistalled, rebooted , and tried to install the new version. The installer fails to complete, and crashes. It hangs at the point of “Database convertation” , seems to be using a whole lot of memory, and crashes without finishing the install. Windows 7 64bit.

I’m sorry to hear about this problem. Please go to the top left GlassWire menu and let me know what version you are using.

Glasswire is currently not installed on my desktop. I uninstalled it and downloaded the latest version. The install fails to complete.

Thank you for the detailed report. We will try to reproduce and fix this problem.

The source data table is being blocked from transferring the data to the destination table . In otherr words something in your PC is blocking the transfer . Having had many battles in the past with Windows doing the same to me I would check your Windows updates and /or that big trojan the (in) compatibility assistant . I am not asking anybody to copy me as what I have done to Windows on my PC would make a lot of people who love MS very angry BUT it works ! no more you cant install this or that ,no more watching as an non-MS approved app I have had for months only flashes up on the screen for a millisecond before disappearing.

Exactly the same issue.
First, GW freezes in “watching network” (or something like this).
Then, I have downloaded the last version and installed over the old one. The installation freezes in the “starting database conversion”, and stay hanged hours and hours.
¿Any suggestion?

@garcianacho Please go to add/remove programs and uninstall GlassWire, then reboot (it’s actually important), then reinstall our latest version but during installation choose the “clean install” option and let me know your results. Unfortunately a clean install will clear your graph data and settings, but it will keep your paid status.

Thanks!

@Ken_GlassWire Up. When upgrading from version 1.2 to 2.0, an error “Database convertation”. Сlean installation - too pornographic option, please make the convertation workable.

1 Like

@11151

Sorry for the problem. Here are instructions on how to backup everything between upgrades.
https://www.glasswire.com/userguide/#Backup_Settings

I tried installing glasswire several times, I click on the install, it completes the install but no icon is created on desktop (i’ve selected add icon to desktop), I dont even see glasswire in my installed programs, please help.

@sona

What OS version are you using? If you try to install again and choose our “clean install” option does it help?

Do you use any unusual security software that stops third party applications from running or starting? If you use something like that, please white list GlassWire.

I’m using windows 10, its my PC, I haven’t installed any other security, only what it came with

Did you try to install again with “clean install” checked in the installer as suggested above? Did it make any difference, or no?

I click on the download, start the install, select the component to install, choose a start menu, it finishes the install but nothing happens, no icon nothing, I dont see the clean install, sorry

@sona

Please delete whatever GlassWire file is on your desktop currently.

Now please click this direct download link for our installer https://download.glasswire.com/GlassWireSetup.exe then once it is downloaded to your desktop please double click the installer and choose the “clean install” option. Please let me know what you see and if that solves it.

I could be mistaken, but I don’t think GlassWire asks you for a component to install so perhaps our installer did not fully download and this is some part of Windows you are seeing? Post a screenshot of what you are seeing if this still does not work for you.

great, this worked for now, thanks for your help.

1 Like

I’m glad GlassWire is working now! Check out this guide to get started using GlassWire:
https://www.glasswire.com/quickstartguide/

I’ve been a happy user of GlassWire for over a year now. Thank you for this quality product!
But…
I am never able to install an upgrade/update to GlassWire without uninstalling and rebooting to get the previous version stopped and removed. If I don’t do this, in the “details” pane, it usually shows “failed” on attempts to stop services or remove them. I used to have this same problem with CrashPlan, so I suspect there is something unusual in my PC’s configuration. Perhaps that’s in the security, or in the drive configuration as I’ve moved the /users folder to the e: drive.

I’d like to do a deeper dive on this. Is the log presented by the “details” button on the install dialog available after that dialog box is closed? (It would be nice to be able to click a button to copy or save that info at process completion, whether it thought it was successful or not.) It would also be nice if the lines in that log included time stamps down to the second or microsecond. That would allow coordination with other logs such as the event log.

Thank you!
–Brian

@BrianKDav

Yes, it must be something with your configuration. We are careful with our upgrades so the user can just launch the installer and install GlassWire on top of itself with no issues. It would be terrible for us if the user had to do some technical thing like kill a process because we’d lose a lot of our user base.

For the logs, we use an SDK for our installer so I’m not sure what all is possible but I will ask if they have some suggestions. Sorry for the issue and if you find the cause please let us know so we can improve.

Our QA tests every update and we are not able to reproduce this on our own machines with normal Windows settings.