Glasswire Firewall prevents LAN seeing internet after a days usage or so

Hi there!

[Updated with image proofs below that this is a GlassWire issue]

New user of Glasswire here. Firstly, love the UX and clean minimalist nature of the tool kudos on that.

However I am having issues 2 times now. After a day or so using Glasswire and enabling the firewall (in ask to connect mode so I can choose what to allow to use the connection) my LAN adapter is prevented from seeing the internet and I have no idea why. It was working just fine - had not added any new rules and then suddenly I get notification saying my connectivity has changed - ie I am now offline - I didnt even add any new rules. If I disable the firewall, it connects just fine. This is a fresh install of windows 10 pro so no weird conflicts going on here either that I am aware of. No competing software installed.

So I figured I delete all the rules in Glasswire that were blocking anything that I had blocked before via GW (mostly my own apps like Chrome or such to test), but no, still cant connect when glasswire firewall re-enabled.

The only way I have managed to fix this was to uninstall glasswire and reinstall whilst checking reset windows firewall settings but this is the 2nd time its happened in just a few days and I cant be expected to do this every few days and then re add all my app permissions again when something gets corrupt with GW…

I have only been using the GW interface - no funny business tinkering on my side and I have no idea what is causing the block for my wired ethernet connection to stop being able to see the internet.

Any help is much appreciated as I am totally lost here.


Update. I have some results after trying out some more things:

  1. If I switch firewall mode to “Click to block” my internet works fine and it respects the current rules I have listed which basically shows apps that are not OS critical as blocked.

  2. If I switch back to Ask to connect mode i lose my internet connection!

It seems that the firewall does not respect the list rendered to the GUI and is actually keeping old rules even though they have been unblocked.

To confirm this I checked the actual windows firewall rules and I can see this happens so this is a bug with your software:

  1. When In “Click to Block” windows firewall shows these active blocking rules:

This correlates with what is shown in my firewall:


Thanks for your kind words about GlassWire and I am sorry to hear about the issue you’re having.

Please note we use the Windows Firewall API for blocking with GlassWire so it’s very unusual for GlassWire to cause connectivity issues.

I recommend going to add/remove programs and uninstalling GlassWire, then going to the Windows Firewall control panel and choosing “restore defaults”.

Now reboot and see if the problem continues. If it does, then it’s not related to us. If it doesn’t continue then please let me know and we can give details on how to log what’s going on with GlassWire. You could then send us those logs and we could diagnose the issue and solve it.

However when I change to “ask to connect” windows firewall gets a tonne of extra rules added even though these processes are listed as not blocked in firewall (see screenshot above) - its like it doesn’t remember I unblocked them!

Sorry for so many replies it seems your website doesnt allow new users to upload more than 1 image at a time.

As you can see though @Ken_GlassWire This is a GlassWire issue not Windows Firewall - these added rules that cause the block come from your software! Please fix bug! Reboot does not help. It persists because its a Glasswire issue. As previously stated reinstalling is not an option as this is a bug with your software that keeps happening after some usage. I can not reinstall every other day. That is not a good use of anyone’s time.

1 Like


Thanks for posting your firewall rules.

If you’ll consider it, please try uninstalling GlassWire completely (exactly as described in my previous post) and make sure the network connectivity issue you are experiencing doesn’t still exist if possible.

Also please note I run “Ask to connect” mode myself, and I don’t experience the issue you are having. Plus I do support for most GlassWire users and I don’t recall this being reported. Otherwise we’d have a lot of people raging against us right now. Internet connectivity issues tend to make people super angry.

Internet connectivity issues are very frustrating and I am very sorry you’re experiencing that. Let’s figure out what’s going on so we can fix this for you ASAP.

Also one last question… are you completely new to GlassWire or have you used older versions before in the past?

@Ken_GlassWire Yep I have reinstalled and it is back working again as expected - I have done this once before already. It seems when im in ask to connect mode, if I block a service, because I am paranoid, and then I realise I need it so I uncheck the fire icon on the left, the firewall does not remember this when in ask to connect mode. That is the only explanation and way I can replicate the issue. My guess is at some point I blocked a process that was needed for network discovery but then when I unblocked it (see screenshot above of glasswire where no system processes are blocked) something causes glasswire to not enforce the currently displayed rules and actually keeps track of previously blocked stuff and reapplies that instead. This is the only logic I can see that causes this bug. I am completely new to glasswire. Thank you for helping me through this. I just built a new PC too, fresh windows 10 pro install, pretty much no other software installed other than mobo drivers and nvidia drivers etc. No other firewalls or antivirus are installed at this point. Just Glasswire + Windows Defender + Windows Firewall


When you removed GlassWire did you go to the Windows Firewall control panel and choose “restore defaults” then reboot? You would need to do that to be sure the rules were completely reset.

@Ken_GlassWire Yes Correct. I forced defaults to be restored and then everything worked fine again after that. And now I am back into my original situation where everything seems fine but I guarantee if I block something critical and then unblock it it stays blocked when in this ask to connect mode as shown by my screenshots above. You can see in my screenshot none of those windows services are blocked but appear in windows firewall when in this specific mode only. When i flipped back to click to block mode it blocked only the ones I had active blocked in the app, and everything worked as expected, but when I was in ask to connect mode it didn’t respect what was showing in the app. This is 2nd time this state occurred in the space of 2 - 3 days. I am not doing anything abnormal here. Just blocking things and then wanting to unblock them from the firewall using the fire icon.

1 Like

Please try it and let me know which app it is that does it. Thanks.

@Ken_GlassWire It is Glasswire that blocks me when in the Ask to connect mode as described above for things I had previously blocked but then unblocked it does not respect this as shown in the screenshots above for windows firewall rules which shows the extra rules it adds when in this mode vs the other click to block mode which acts correctly.


Sorry for the problem and sorry for any confusion.

Is your LAN adapter still prevented from seeing the Internet? Or did that problem go away? That was the main thing I thought we were focused on first.

The problem is that I can make it go away by reinstalling Glass Wire but this is not an acceptable solution because this is the only fix every time it happens - which I explained above how this situation seems to occur.

Glasswire should not get into this state in the first place. When I have only used the Glasswire UI to do the blocking and unblocking This is most certainly a bug with the software and needs to be escalated to engineering to fix. As an end user I have not done anything wrong - I used Glasswire as intended to block and unblock certain apps but in the mode described above it does not respect those modified unblock rules and instead applies blocks to items previously blocked with its own custom rules within windows firewall as shown in screenshots above.

So yes, reinstalling Glasswire with clean install and reset of windows firewall fixes the issue but I cant be expected to do that every time this happens. That is not acceptable for a paid product. Thanks.


Sorry for the problem. I guess I don’t understand.

So your LAN adapter is prevented from seeing the Internet currently, or are things OK now? Are you saying that your PC went back to where the LAN adapter cannot connect and you saw the Windows globe icon again?

I’m glad to help with the other issues you are having too but I wanted to confirm that was solved for you first.

@Ken_GlassWire So that is the only issue I had - the globe icon appears when GlassWire blocks my LAN adapter due to the firewall settings it applies shown in the screenshots above which are incorrect. It blocks things I previously blocked even though they are now unblocked. The only way I can resolve it is to reinstall GlassWire each time and force the do reset option. If I disable the firewall it connects, so it is def a Glasswire thing. After a reinstall it works fine again, but I am sure at some point in the future I will block a program I need and I will be in the same situation again and will have to reinstall all over again and re add all my apps again… Let me know if any questions on that or if that now makes sense? Thanks!