Glasswire Installation Freezes

Hi to all!

First of, I installed this awesome piece of software in my home network and I love it!
My problem is that I cannot install it in my main rig for some weird reason.

I,m trying from v1.1.31
Every time I try to install it, it does not give me any error it just hangs…
I’ll post the log from the installer.

I tried with compatibility for Win7 & Win8, also I run it as Admin, I also tried to uninstall my anti-virus just in case
but with no luck…
I,m running Win10 Pro x64

Here is the log.

Output folder: C:\Program Files (x86)\GlassWire
Extract: GWCtlSrv.exe… 100%
Extract: GWIdlMon.exe… 100%
Extract: GlassWire.exe… 100%
Extract: GWUnlock.exe… 100%
Output folder: C:\Program Files (x86)\GlassWire\platforms
Extract: qwindows.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire\imageformats
Extract: qico.dll… 100%
Extract: qjpeg.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire
Extract: GeoIP.dll… 100%
Extract: Qt5Concurrent.dll… 100%
Extract: Qt5Core.dll… 100%
Extract: Qt5Gui.dll… 100%
Extract: Qt5Svg.dll… 100%
Extract: Qt5Widgets.dll… 100%
Extract: Qt5WinExtras.dll… 100%
Extract: icudt54.dll… 100%
Extract: icuin54.dll… 100%
Extract: icuuc54.dll… 100%
Extract: msvcp120.dll… 100%
Extract: msvcr120.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire\lang
Extract: de_de.qm… 100%
Extract: en_us.qm… 100%
Extract: es_es.qm… 100%
Extract: fr_fr.qm… 100%
Extract: it_it.qm… 100%
Extract: ja_jp.qm… 100%
Extract: ko_kr.qm… 100%
Extract: pt_br.qm… 100%
Extract: ru_ru.qm… 100%
Extract: zh_cn.qm… 100%
Extract: zh_tw.qm… 100%
Output folder: C:\Program Files (x86)\GlassWire\copyrights
Extract: boost-license.txt… 100%
Extract: geoip-license.txt… 100%
Extract: google-license.txt… 100%
Extract: libcurl-license.txt… 100%
Extract: libqxt-license.txt… 100%
Extract: openssl-license.txt… 100%
Extract: qt-license.txt… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver\x86
Extract: gwdrv.cat… 100%
Extract: gwdrv.inf… 100%
Extract: gwdrv.sys… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver\x64
Extract: gwdrv.cat… 100%
Extract: gwdrv.inf… 100%
Extract: gwdrv.sys… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver
Output folder: C:\ProgramData\GlassWire\service
Extract: GeoIP.dat… 100%
Extract: storage.db… 100%
Output folder: C:\ProgramData\GlassWire\service\log
Output folder: C:\Program Files (x86)\GlassWire
TrustedPublisher "Trusted Publishers"
Related Certificates:

Exact match:
Element 1:
Serial Number: 06384809953f926c77500e887d1bbea0
Issuer: CN=Symantec Class 3 SHA256 Code Signing CA, OU=Symantec Trust Network, O=Symantec Corporation, C=US
NotBefore: 24/3/2015 2:00 ?i
NotAfter: 23/5/2016 1:59 ?i
Subject: CN=GlassWire, O=GlassWire, L=Austin, S=Texas, C=US
Non-root Certificate
Cert Hash(sha1): e0 d2 22 52 e2 52 82 68 d3 8b 0f 8f ff 3d 7f 63 8f 94 1b 54

Certificate “GlassWire” already in store.
CertUtil: -addstore command completed successfully.
Execute: “G:\WTEMP\nspDAF2.tmp\GWInstSt.exe” “https://www.glasswire.com/stat/install.php?v=1.1.41&os=Ten&platform=x64&update=0” "nsis$$.tmp"
TrustedPublisher "Trusted Publishers"
Related Certificates:

Exact match:
Element 1:
Serial Number: 06384809953f926c77500e887d1bbea0
Issuer: CN=Symantec Class 3 SHA256 Code Signing CA, OU=Symantec Trust Network, O=Symantec Corporation, C=US
NotBefore: 24/3/2015 2:00 ?i
NotAfter: 23/5/2016 1:59 ?i
Subject: CN=GlassWire, O=GlassWire, L=Austin, S=Texas, C=US
Non-root Certificate
Cert Hash(sha1): e0 d2 22 52 e2 52 82 68 d3 8b 0f 8f ff 3d 7f 63 8f 94 1b 54

Certificate “GlassWire” already in store.
CertUtil: -addstore command completed successfully.[/quote]

Thanks in advance!

Thanks for this log. We’ll investigate and try to fix it.

Thank you! Looking forward for your answer!!

This is the point where it freezes every time…

I can see why it would freeze. The log file that you output and uploaded states that it is looking in G:\WTEMP\xyz.tmp\GWInst.exe

Did you change your C: drive to G:? or what is that there? Are you running this off a flash? Try copying to desktop.
Also, your GLASSWIRE CERTIFICATE is already installed. Perhaps ask if they have a install option with a flag for no certificates during install. I am sure it will resolve to one of the following conditions:

1.) It could possibly be an unhandled error. (An exception or fault in the code with no instructions to properly handle this error).

Or my bet is on number, 2:) There is an issue with either a third party software for security. Like your antivirus for instance or firewall or some type of download if you have one. These might already be in place by default thanks to windows lately.

We all know they are doing all kinds of stuff lately that goes against standards and best practice… Perhaps they put in some type of restraint that prevents the HTTPS (SSL Version of HTTP) protocol from kicking in when launched from a jump drive or temp drive other than C:. I dont know how your setup is. Like as far as antivirus and third party apps. You might not even be able to tell so easily yourself anymore! They have changed the Windows OS so much. I haven’t had a system wide error since perhaps XP or VISTA (I’ll just say XP cause i never even used vista really). Now the last time I installed Windows 10, it worked for a couple days before I couldn’t even open the default apps like CALC and that music player thing. Try to open calc. If you can then you know its not that. If you cant open a lot of default programs, for instance they just close out immediately upon opening them, you will know you have a bigger issue.

Good luck !

Oh and I just noticed that you said you tried to install with compatibility mode engaged. You will probably have to go through your certificates and remove all files and registry settings pertaining to GLASSWIRE. I am not going to tell you how because this is risky advanced stuff, also it would be too involved. It might not even be the problem. Maybe put in a request for the installer to have a “clean up” option. That way the folks at GlassWire can write and add another feature for their software.

I bet Edge just can’t handle itself. Maybe try to download a new browser making sure to set it as the Default Browser so that HSTS URL can be parsed to that PHP script properly.

Hi! Thank you for your time!

  1. It is not a typo, I did change the temp folder from C to G cause I don’t like too much writes into my SSD
  2. I don’t believe it is a conflict with a security program cause I uninstalled my AV just in case…
  3. I deleted glasswire from Temp, program data, program files but to be honest for some weird reason I didn’t think about cleaning my registry manually rather just running Ccleaner

I’ll try again by putting my temp to C and manually cleaning my reg.

I have also another PC with exact the same setup and glasswire installs just fine, the only difference is that temp folder is on C

OK I managed to install it, I had to put the .exe and launch it from C… Thanks again for your answers!!

check this log please,

Output folder: C:\Program Files (x86)\GlassWire
Extract: GWCtlSrv.exe… 100%
Extract: GWIdlMon.exe… 100%
Extract: GlassWire.exe… 100%
Extract: GWUnlock.exe… 100%
Output folder: C:\Program Files (x86)\GlassWire\platforms
Extract: qwindows.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire\iconengines
Extract: qsvgicon.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire\imageformats
Extract: qico.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire
Extract: EasyHook32.dll… 100%
Extract: Qt5Core.dll… 100%
Extract: Qt5Gui.dll… 100%
Extract: Qt5Svg.dll… 100%
Extract: Qt5Widgets.dll… 100%
Extract: Qt5WinExtras.dll… 100%
Output folder: C:\Program Files (x86)\GlassWire\lang
Extract: de_de.qm… 100%
Extract: en_us.qm… 100%
Extract: es_es.qm… 100%
Extract: fr_fr.qm… 100%
Extract: it_it.qm… 100%
Extract: ja_jp.qm… 100%
Extract: ko_kr.qm… 100%
Extract: pl_pl.qm… 100%
Extract: pt_br.qm… 100%
Extract: ru_ru.qm… 100%
Extract: tr_tr.qm… 100%
Extract: zh_cn.qm… 100%
Extract: zh_tw.qm… 100%
Output folder: C:\Program Files (x86)\GlassWire\copyrights
Extract: apache-license.txt… 100%
Extract: apache-notice.txt
Extract: boost-license.txt… 100%
Extract: easyhook-license.txt… 100%
Extract: geoip-license.txt… 100%
Extract: google-license.txt… 100%
Extract: libcurl-license.txt… 100%
Extract: libqxt-license.txt… 100%
Extract: openssl-license.txt… 100%
Extract: qt-license.txt… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver\x86
Extract: gwdrv.cat… 100%
Extract: gwdrv.inf… 100%
Extract: gwdrv.sys… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver\x64
Extract: gwdrv.cat… 100%
Extract: gwdrv.inf… 100%
Extract: gwdrv.sys… 100%
Output folder: C:\Program Files (x86)\GlassWire\driver
Output folder: C:\ProgramData\GlassWire\service
Extract: GeoLite2.mmdb… 100%
Extract: storage.db… 100%
Output folder: C:\ProgramData\GlassWire\service\log
Output folder: C:\Program Files (x86)\GlassWire
Installing Microsoft runtime libraries
Microsoft runtime libraries installation completed
Execute: “C:\Users\admin\AppData\Local\Temp\nshB4FE.tmp\GWInstSt.exe” “glasswire/stat/install” “nsis$$.tmp”
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.

It looks like the GlassWire service is already running. Perhaps you have the Steam version also installed? Please go to add/remove programs or Steam and completely uninstall GlassWire, then reboot, then try to install again with our “clean install” option in our installer.

Please don’t use third party uninstallers because it can cause this issue due to it not removing our service.