Glasswire & Intel Dual Band Wireless-AC 8265 issues


#1

I’m using the latest drivers for my Intel Wireless-AC 8265 network adapter. Every now and then, Windows 10 will not find any wifi at all, as if the wifi adapter is removed or disabled. If I try to disable and re-enable the NIC, nothing happens. The wifi option also disappears from this list:

I’ve found that if I restart the WLAN Autoconfig service, it will fix the issue. The thing is, every time I restart the service, it also says that it will restart the Glasswire Control Service. I suspect that Glasswire is causing my WiFi to crap out and so I have disabled the Glasswire Control Service and my WiFi has been running fine for the last couple of days.

I have already unticked the WiFi Evil Twin monitoring in Glasswire, but that didn’t help. Really don’t want to do a clean uninstall as it will wipe all my Glasswire firewall rules.

I’m on the latest Windows 10 build, using a Lenovo T480s laptop.

Any idea what could be causing this?


#2

I doubt that this is caused by GlassWire because of widely reported problems with that wireless adapter and other adapters in that Intel range of products. There are many users reporting problems with lost connections particularly on the 5GHz band. You could check other problem reports - here’s a couple of examples below - and see if there are similarities with your problem:

https://communities.intel.com/thread/123780

If GlassWire were causing this then I’d expect the team to have more GlassWire users reporting the same issue.

The WiFi option disappears from your connection list because the adapter is no longer functioning. This is the sort of problem that often develops with old adapters that only function intermittently.


#3

I disagree.

Firstly, it’s not that the wifi has dropped off. The issue is that none of the SSIDs are showing and it’s as if there’s no wifi adapter installed at all.

Secondly, the Lenovo T480s is a new laptop and came out a few months ago. The Intel chipset is relatively new, so it’s not an issue with “old adapters” or old drivers or old chipsets.

3rdly, I’m not connected to 5Ghz, I’m connected to 2.4Ghz. The issue is there regardless if I’m connected to a SSID.

The point is, I can replicate the issue by enabling Glasswire Control Service. If disabled, everything is fine.


#4

I wasn’t trying to insult your intelligence by saying that old adapters or drivers is an issue for you. I was trying to say that adapters not functioning intermittently looks just the same whether it is the problem you have or the more common problems with older adapters.

Anyway, it is your choice whether you investigate the potential adapter/driver issues while waiting to see if this can be resolved through the GlassWire team. I would be pursuing both paths.


#5

No offense taken.

I’ve already tried resolving the adapter/driver issues myself and so far the fix that does work consistently is to disable the Glasswire service.

To be honest, I’m not too surprised. I have raised many Glasswire related issues in the past, some were performance related, some were buggy issues. It’s a lot better than before, but unfortunately it seems to be playing up with my adapter.


#6

I have never seen a report like this before. Please give details on how we can recreate this and we’ll try to do so.

Is GlassWire’s Firewall off or on with your PC?


#7

Glasswire Firewall is on. Using Ask to Connect mode.

Running latest Windows 10 1803 build. Drivers fully up to date.

I’m not exactly sure how to replicate the issue, but it seems that after my laptop goes to sleep and resumes from sleep, the SSIDs will drop off completely. The WiFi option under the Windows Settings will disappear. Network adapter under “ncpa.cpl” is still enabled, but can’t connect to any SSIDs because the WLAN Autoconfig service is bung. Fix it to restart the WLAN Autoconfig service, which always requires a restart of the Glasswire Control Service.

WLAN NIC power saving settings is off. Any WiFi sleep related settings are disabled under Power Options.


#8

@Ricky

If you go to GlassWire’s settings/security is your “Evil Twin” GlassWire alert on or off?


#9

Hi Ken,

As mentioned in OP, I have disabled the Evil Twin feature.

image

image

To give you a better idea of the issue, this is what it looks like:

image

There isn’t a hardware FN key to disable or enable the WiFi radio and there isn’t a setting in BIOS to control this.

Running ncpa.cpl, we can see NIC isn’t disabled:

image

WiFi option is missing under Windows Settings (but it was there in my screenshot in OP):

Restarting WLAN Autoconfig service:

image

Sometimes restarting it won’t work. I have to perform the following:

taskkill /F /FI “SERVICES eq WlanSvc”
taskkill /F /FI “SERVICES eq GlassWire”
net start WlanSvc
net start GlassWire

Wifi drivers fully up to date. Have done a clean uninstall and deleted software from devmgmt.msc, then reinstalled wifi driver. Have tried several versions already.

image

As mentioned eariler, for me to replicate the issue, put laptop into sleep mode and wake from sleep. If I disable the Glasswire Control Service, this issue won’t occur even when I put my laptop into sleep and wake from sleep multiple times.