GlassWire is dumping its you-know-what all over my desktop

09/09/2020  11:55 AM     1,935,424,030 GWCtlSrv.exe.4504.dmp
09/09/2020  07:01 PM     1,985,030,568 GWCtlSrv.exe.5824.dmp
09/11/2020  04:48 PM     1,993,133,815 GWCtlSrv.exe.5992.dmp
09/14/2020  02:38 PM     1,971,353,724 GWCtlSrv.exe.5952.dmp
09/15/2020  08:56 PM     1,988,877,783 GWCtlSrv.exe.9196.dmp


There is also this:

Followed by this:
(Imagine a screenshot of GlassWire here with an icon of what looks like a sad Mac and the test “service stopped running”. As a new user I am not allowed to post this screenshot.)

These two screenshots are preceded by this:
(Imagine a screenshot of GlassWire with the text “visualizing network” or something along that line. I don’t have that screenshot.)

Is there a solution to this other than reinstalling, rebooting, uninstalling, rebooting, clean installing and resetting the Windows firewall settings to its default settings and rebooting? I have not tried letting the installer clean all the data and start fresh with a blank slate, but I might as well just do that at this point or stop using GlassWire altogether (I use the free version anyway). This problem started I think some time back after I finally gave in to the prompt that kept bugging me about upgrading (or updating) to a new version. Until then it worked fine.

Clearing all data during installation helped. All gone and the program is working… not ideal, but hey… you win some, you lose some.

Now I can clean up 9.19 GB (!!!) worth of dump files and relieve that starved SSD (from 17 GB free to 26 GB free).

Wow, sorry about that! If it happens again please email us the .dmp file. We can find the cause of the issue and solve it.

Yeah… the good news is that it’s been stable since.

Is the desktop the default location for dump files?

Is it possible to export the traffic data, logs, the works? I might be able to extract it from a backup. Would I be able to merge it with current data set without corruption?


.dmp files are generated by Windows, not GlassWire. I believe the desktop is the default location.

It’s possible to move the database.

Good timing! I was just looking at this. I found this path.


It contains a number of different db files.


What are they? To backup and restore graph data, I only need to extract the glasswire.db file?

In addition to above files, there are similar file sets in a “stats” sub folder.


I take it these are like slaves or children, the main one I need is the glasswire.db ? I can tell by their name that these are databases used to display graph data within given time intervals.

Also what is the significance of %USERPROFILE%\AppData\Local\GlassWire and do I need to extract that as well for a successful restoration?

If I may bother you with one more question… within the GlassWire parent folder in ProgramData, I find these three folders:


The last one just contains an empty “log” folder. The one in the middle contains its own glasswire.db file that’s several megabytes in size. Is this in fact the old database that I used before I clean installed GlassWire? Does GlassWire automatically backup the “service” folder like this? This might save me the trouble of having to extract it from a system backup.

It didn’t work as expected.

I have extracted these db files.

1    glasswire.db    68.2M
2    glasswire.db    33.4M
3    glasswire.db    5.55M

First one is the oldest and most comprehensive, I extracted it from a system backup of previous GlassWire installation. Along with the second one which was living in a folder called “service.backup_20200901_160354”. The third one is from the last GlassWire installation.

I did everything as described in the instructions at:
(I can’t post links.)

I uninstalled GlassWired and installed it again using the “clean” option and then uninstalled it again. The only difference is that I at that point replaced the current glasswire.db file of 5.55M with the oldest of them at 68.2M and then reinstalled GlassWire. I did all the renaming tricks as well, in Local and in ProgramData folder.

(Sorry, new users can only put one embedded media item in a post.)

At least my desktop was not used as a dumping ground this time. (Also, I noticed the db file size change to 32.2M during reinstallation. This is less than 68.2M I copied over before reinstallation, and less than the 33.4M I had in the second backup that I think GlassWire automatically created at some point.)

How do I restore that 68.2M file? Could it be that it’s corrupted? I could try a different one, now that I have three different to play around with.

My 68.2M file was automatically moved into a new folder called “service.backup_20200919_165916”. So it didn’t take it.


What version of GlassWire were you using that had the previous database, and I guess you just installed our latest version, is that correct?

Please confirm the version of GlassWire that created the database you’re trying to move. I think this issue may be because our latest software uses a different database format than the previous version. That’s why the latest version is supposed to convert your database to the new format. Unfortunately though some people have seen a database corruption in some situations.

I’m not sure what version it was. But these are the versions I have used in the past…

2.0.123    8/18/2018
2.1.167    11/24/2019
2.2.241    9/1/2020

Dates indicate when I downloaded the EXE installer files of given version. So I suspect it was 2.1.167 before I installed the newer version which was likely 2.2.241.

When did you introduce this breaking change? (I suspected as much.)

The EXE version I’m currently using for testing is:

All three db files I have here are SQLite version 3.

53 51 4C 69 74 65 20 66 6F 72 6D 61 74 20 33 00    SQLite format 3

I tried the whole thing all over again now, but with a twist. So uninstall, clean install, uninstall, and then insert the line below and reinstall.


I wanted to use this line to ensure that the right db file is fetched during initialization. I did not bother renaming GlassWire folders back and forth, I’m not sure what the purpose of that is anyway, as the content never changes. Other than to ensure that GlassWire creates a new set of folders with the same names (and avoids overwriting the old ones), only to have them removed manually after uninstalling GlassWire again and renaming the old folders back into place (so I jumped right to the end instead, cutting to the chase). (I find it’s easier to just copy out those folders if you need their contents and put them back in when you need to.)

So anyway, the results are the same. Attempting to connect… 1, 2, 3, 4, dead.

I did some detective work, using the system backup I have to go back in time and examine the EXE files that were in the Program Files (x86) folder at given times.

Date          Event
2018-08-16 is downloaded
2019-11-24 is downloaded
2020-02-29 is running on the system
2018-08-17    33.4M db file created
2020-09-01 is downloaded
2020-09-01 is running on the system
2020-09-01    68.2M db file created and modified
2020-09-08    33.4M db file modified
2020-09-15    Forum thread created about crashing GlassWire
2020-09-15    5.55M db file created
2020-09-19    5.55M db file modified

I believe was the very first GlassWire version I downloaded and installed (more than two years ago). I have been using the free version ever since. I mostly use it for the statistics, seeing how much data I consume month by month, so it’s a pity I had to lose it between software updates.

I will assume this old data is irrecoverable now and give this a rest. But you need to implement a data export and import feature. I rather rely on that than fiddling with database files. That’s the way to make the data portable and keep data integrity.

I used my backup of 1 September to extracted the whole GlassWire folder from ProgramData and from AppData (Local) and placed them at their default locations right after doing a clean install, uninstall, normal (non-clean) install and uninstall. I then did a normal (non-clean) install of GlassWire 2.2.241 and I could see the installer converting the database.


The resulting file is 32.2M (as seen before) and a new folder called “service.backup_20200919_184410” was created right next to the “service” folder, containing a glasswire.db file of size 68.2M (also seen before). The db file that was placed in before installation was sized 68.2M so this is likely the same file.

But after running GlassWire it gets stuck with the message “visualizing network” and then a “GlassWire Special Offer” message appears in the foreground leaving the program stuck in this visualization process.

1 Like

Confirmed! It is the same file. So it looks like after converting the 68.2M file into a 32.2M file (the new format), GlassWire moves the old original to one of these auto-generated service.backup_YYYYMMDD_HHMMSS (year, month, day, hour, minute, second) folders.

But most likely the conversion results in a corrupted database file, like you said. So the best solution to this is most likely to be a step back to the version that did not introduce a new database file format. I don’t know which one that is, but I’d say 2.1.167 looks like a good candidate.

I restarted the program and now it’s back to its normal “Connecting to the Local Server”.

I found the change log here:
(Sorry, new users can’t put links in posts.)
Sorry! But you can always google it…

It looks indeed like 2.1.167 was the last version to use the old database file format.

Version 2.2.201 - (May 20, 2020)
GlassWire now uses an improved remote access system for remote monitoring.
This system is not compatible with our previous system so you’ll need to update your client and server software both with this new version. If you do not have access to your remote server due to quarantine or for some other reason, you should not upgrade this version.

@Ken_GlassWire is this the change of format you were referring to?

(You’ve reached the maximum number of replies a new user can create on their first day. Please wait 4 hours before trying again.)

I did the same thing now, but with 2.1.167 version. There was no database conversion during installation and the program runs like before:

If it ain’t broken, don’t fix it! When broken, blame yourself for giving in to the opinions of others. Such as…

GlassWire 2.2.241 is now available.
New features and improvements.

New features alright, but I wouldn’t exactly call it improvement…

But do quote me to let me know when you have overcome the limitation of corrupt output of database conversions and I might consider updating to the latest and greatest version.

Now I can give this a rest… :wine_glass: :champagne:

1 Like