Glasswire is not blocking any outbound connections when using a VPN

Hi there, after reading your forums for a while & solving some of the issues I faced after buying & downloading your firewall (had to run windows updates etc so I could get glasswire to connect) there’s another issue.
I did a clean install so there would be no interference (deleted the glasswire program data folder too) and activated the subscription but the firewall is not blocking anything at all, tried all 3 modes (click to block, ask to connect & block all) with no luck.
Windows 7 Ultimate 32bit here, please advise. :slight_smile:

Update: It seems that Glasswire is running as intended when using without a VPN. Eg blocks specific browser from accessing the internet but when connecting to a vpn the same thing won’t happen, even if the browser is blocked from accessing the internet it still does.
Here’s a screenshot:

*I don’t want to name the vpn software but still it’s widely used & I’ve combined it with Glasswire before with no issues.

Edit 2: I found this: Firewall blocking doesn't work when VPN is active
Facing exactly the same issue but not with Nord VPN :slight_smile:


I have not seen any recent issues with any VPN and GlassWire.

I have a recommendation that can find and possibly fix the problem.

Uninstall GlassWIre in add/remove programs. Go to your Windows Firewall control panel and choose “restore defaults”.


Reinstall GlassWire using its “clean install” and “reset firewall” option.

Now turn on GlassWire’s firewall and begin blocking.

Hi & sorry for my late reply :slight_smile:
I kind of solved the problem switching over to another VPN, the problem remains with IPV and I think it has to do with their Proxy scrambler (to avoid company firewalls). To reproduce my problem you need:

+Windows 7 Service pack 1 (up to date with system updates) x86-x64 both will give the same result
+Windows firewall defaulted
+IPVanish with all security options checked (Hide port, KillSwitch, etc)
UDP or other configuration (won’t make a difference)

Now when you actually use IPV, glasswire will go dead, nothing will work as I’ve shown in the screenshot above too. Glasswire will work as expected while using other vpn services. So it’s kinda odd but thanks for your time. :slight_smile:

Thanks, we’ll check that out and see if there is something we can do.

However if it’s a feature made to bypass things and you’re running it on your own PC perhaps we can’t do anything.