Glasswire isn't showing any data after installing VirtualBox

I have been using Glasswire for a few years and it has worked perfectly, but 3 days ago installed VirtualBox on my Windows 10 machine and ever since then it’s not been showing any new data. I can go back from the date before I installed VirtualBox and look at that data, but nothing shows after that date.

I’m guessing it’s showing data for the Virtual Box adapter, and I’ve had a look at the glasswire settings, but there’s no option to change which adapter it records data from.

@Divanshu_Verma

Sorry for the problem. If you uninstall GlassWire, reboot, then reinstall it using the “clean” install option does it start working?

I have used GlassWire with Virutalbox and I have not seen this problem yet. Very weird.

Thanks, that worked :slight_smile:

1 Like

thank you for helping us

Just an FYI in case anyone was wondering how to monitor VM traffic with GlassWire, but I have noticed that if you set your VMs to use “NAT” under VirtualBox networking, all of your VM network usage will be listed under the VirtualBox Manager app in the GlassWire “Usage” tab.

1 Like

The last months GlassWire was also able to display traffic from VirtualBox instances using “Bridged Networking”.

Unfortunately this does no longer works since VirtualBox 6.1.18 :frowning:

@transparent

Thanks for your report. Perhaps there is documentation about what’s changed and some other mode they use can solve this?

Unfortunately the change log of VirtualBox only contains one entry that may be related: “UDP checksum offloading in e1000 no longer produces zero checksums” (the VM uses a virtual e1000 network card).

Theoretically VirtualBox is open source but the source code is only available via SVN and the Web-UI isn’t really useful to list the changes and the SVN server itself is painfully slow :frowning:

Edit: I had to remove the links to to the changelog and the SVN as the forum does not allow it.

1 Like

@transparent

Does rebooting your PC make any difference? Sometimes with these virtual adapters there can be a temporary issue, but rebooting solves it.

Unfortunately rebooting has no effect.

Besides that limitation GlassWire is still a very useful traffic monitoring tool for the rest of the system…

1 Like

I will ask our QA to investigate this issue and see if we can recreate it.

The API we use for network monitoring should pick up all data on your PC.

Based on what I have read in the Superuser answer of "How does bridged networking work in Virtualbox " (sorry still unable to post links) the used interface by the bridged network feature of Virtualbox sounds to me like an interface that would be also make sense to be used by GlassWire:

With bridged networking, VirtualBox uses a device driver on your host system that filters data from your physical network adapter. This driver is therefore called a “net filter” driver.

May be it is just a matter of “execution order” in case GlassWire also uses a net filter? At least I can see entries from VirtualBox and GlassWire in the output of netsh wfp show filters.

The API we use for network monitoring should pick up absolutely all adapters. It’s quite strange it has this issue with VirtualBox. We will try to recreate it.