Glasswire Service Stopped Running - Elite and Free (Solved)

Experiencing this on multiple systems (Elite and Free) both fresh install (after a PC wipe) and fresh install with reset settings on an existing PC.

Tried the fixes that are already in the forum, and they do not seem to work. The problem started after updating to the latest version of GW.

Every time I restart the service, or try to, it is creating a 77-80mb dump file on my desktop.

OS: Windows 10 Pro

1 Like

Same here, 207 MB dump file GWCtlSrv.exe.6500.dmp on my Desktop

1 Like

Confirmed on two different devices, it suddenly stopped to work today.

EXCEPTION_RECORD: (.exr -1)
ExceptionAddress: 770ae6eb (ucrtbase!abort+0x0000004b)

  • ExceptionCode: c0000409 (Security check failure or stack buffer overrun)*
  • ExceptionFlags: 00000001*
    NumberParameters: 1
  • Parameter[0]: 00000007*
    *Subcode: 0x7 FAST_FAIL_FATAL_APP_EXIT *

PROCESS_NAME: GWCtlSrv.exe

04b2f578 770b0167 009b84f4 009b8408 04b2f63c ucrtbase!abort+0x4b
04b2f58c 770af6e2 000000f5 770b0240 07965be4 ucrtbase!common_assert_to_stderr<wchar_t>+0x54
04b2f5a0 770b0256 000000f5 003ba341 04b2f61c ucrtbase!common_assert<wchar_t>+0x46
04b2f5b0 003ba341 009b84f4 009b8408 000000f5 ucrtbase!_wassert+0x16

1 Like

https://www.glasswire.com/contact/

The DMP can usually show us exactly what’s wrong. Could you please email it to us using a cloud service like Google Drive?
@crogge @Wintermute @God

same here , The glasswire service stopped running.
started today and restarting glaswire or pc will not help.

1 Like

We have found the issue and we found it can be fixed easily. We are urgently working and I’ll announce when the fix is live.

It’s related to our “suspicious host” feature, so we can actually fix this on the web side.

2 Likes

Me too.

The GWCtlSrv.exe process shows as suspended in the task manager. The Glasswire Control service immediately terminates every time I try to start it. I removed my 3rd Party AV software. I have VPN software, but don’t have any sessions active. ExpressVPN

1 Like

@Ken_GlassWire

I sent dumps a few minutes after my forum post.

1 Like

Done, 2 .dmp files via Google Drive

1 Like

We implemented a quick fix. Could you reboot and see if GlassWire is working now?

I didn’t confirm it with our team yet but I think it’s live if you want to try it?
@God @crogge @Wintermute @foxdragon @Sean_Franzen

The fix is now live. You don’t have to do anything on your end, just restart GlassWire. Please let us know your results everyone.

It was an issue with the suspicious host list format causing a crash due to a the list temporarily going blank I think.

1 Like

It’s working for me now.

1 Like

That’s great news. Thanks everyone for reporting this and sending DMP files. We couldn’t have done it quickly without your help.

It could have been serious for everyone because even @god was affected. :hugs:

I had the exact same problem. My first error hit at exactly 9:02pm last night according to my Event Viewer. I spent 5hrs trying to fix this myself which including the clean install and now I’ve lost all my data that I had kind of needed to keep :frowning: My firewall data is also all reset :frowning:

After starting the computer up this morning it wasn’t working for me still but after seeing this post I had to go into Services and force start it again and it has been running for about 5 minutes now without crashing so I’m hoping this was my problem too. I’ll keep an eye on it.

I wrote to support last night and included a link to a dump file as well, just as a heads up. I never got a confirmation or response back so I’m not sure if it went through. I’ll post back if I have further problems. Thanks for the fix, despite having to lose all my data and firewall settings. At least I can monitor my bandwidth usage again which is the important thing on my metered connection.

1 Like

it still don’t seem to work here ( free version ) i don’t know where to upload the files but i seen they become less than half if i zip them so if you pm me a link to where you want them uploaded

not working for me…paid version

@Nik_Farmer

The issue these others experienced is now fixed. If you have restarted GlassWire and you are still having this issue please check the list here.
https://www.glasswire.com/faq/#glasswire-cant-connect-local-server

Then follow up here GlassWire Service has Stopped Running FAQ if it is still not working.

I will close this thread because this issue was due to a temporary bug that is now fixed.

Still have the issue? We can help!
If anyone else is experiencing this please restart GlassWire, then follow the FAQ link. Then feel free to follow up in this separate thread.