GlassWire won't install - Windows Server 2019

Hi,
I’m trying to install GlassWire on Windows Server 2019 (v1809 Build 17763.914). This is a clean installation of Windows, currently up to date.

SFC produces no errors, the installer fails after the “Execute GWInstS.exe” step.

2.1.140error

I also tried the 2.1.140 installer, it progressed past this step but gave a bunch of errors regarding MSVCP140.dll and QtCore5 once it was installed and I tried to open it. Trying a clean install did not work, and the VC++ Redistributable is installed.

@FineTune

We had another issue today that was just fixed. I am not sure if it’s related to your issue or not, but in case it is can you try to install again now? Please be sure you’re using our latest software from www.glasswire.com.

Hi,
I tried that but didn’t work. It went to uninstall the old versions and threw the same errors (MSVCP can’t be found) and then upon installation it did the same “more help is available by typing net help msg 2182” error.

@FineTune

I think if you’ll run Windows Update it’ll solve the issue, but if you don’t want to do that you can check this very old thread from the Microsoft Answers website that suggests installing some specific things directly from Microsoft.

https://answers.microsoft.com/en-us/windows/forum/windows_other-performance/msvcp100dll-missing/9a687c31-0619-4ee9-b511-020985e29b5f

Nope, that didn’t fix it. I’ve installed the VCPP 2014 redistributable (which is what the 140.dll represents) and have checked for updates - neither version works.

It’s a shame because I was really looking forward to trying this software but unless it can be fixed I’ll just end up using a different program

@FineTune

I found this video that suggests a fix for “cannot find MSVCP140.dll” if you’d like to try this instead.

The DLL is already in system32. No luck. Are you guys able to test if GlassWire is compatible with Windows Server 2019?

@FineTune
Yes it’s supported and we have many customers who use that platform. Do you not see this error with any other applications?

It seems to be a common problem that’s unrelated to GlassWire. For example the video above has close to 400K views.

I’m sorry for the problem. I’ll see if our team has some ideas but it seems to be an error with your OS install so I’m not sure what we can do.