Glasswire Wont open

I am using Windows 10…just downloaded the Glasswire app no problem but when I try to open it says there is an “unspecified error”. Tried it twice with No Joy…any thoughts/assistance are welcome

Strange. Could you delete that installer, then download again? Did you download from GlassWire.com?

Thanks for the quick reply & yes, I downloaded from glasswire.com & tried it a 2nd time with same results…open to any suggestions.

@tsull06

We discussed your problem this morning and we’re unsure how this could be happening. The error “unspecified error” is not an error from GlassWire.

Could you email us a screenshot of what you’re seeing, or post it here? https://www.glasswire.com/contact/

Do you have this problem with any other installers? Please try launching a Firefox installer and see if it launches for you. https://www.mozilla.org/en-US/firefox/desktop/

Good morning…thks for hanging in there on this…attached is the screenshot.
I have not had problems with other installers including the link you.
As an aside, I did try the glasswire download on Firefox…maybe re-try on Edge?
I have a screenshot but not sure how to attach it in this forum…so if you’d send me an email address i would be happy to send.
Best,
Tim

Tim,

Yes, please try to download our file on Edge and see if it allows you to launch it. We received your screenshot, thank you.

It appears the error you are seeing is not a GlassWire error so it seems to be coming from Windows or from the installer tech we use. We’ll investigate further and try to figure out a solution.

I was able to download it successfully on Edge. I look fwd to trying out your product.
Thanks again,
Tim