Google Play Music Desktop Player


#1

Hi Guys,

Having some issues using Google Play Music Desktop Player - googleplaymusicdesktopplayer dot com

It won’t connect when I have “Ask To Connect” enabled and nothing displays as being blocked or pops up to ask for permission to connect.

Soon as I change it to Click to Block it works fine.

Have tested it on 3 PCs now all with the same issue.

Any ideas?

Thanks


#2

Strange. Could you reboot and see if the problem continues?


#3

Hi Ken,

It was the first thing I tried :slight_smile:
I’ve also confirmed the issue on my laptop which is a new Windows 10 build.

Exactly the same issue.


#4

It shows up for me. You don’t see this for your GlassWire version?


#5

I have an idea… I think this interfaces with IE or Chrome. Do you have IE or Chrome blocked under your Firewall tab? I think this app uses a Chrome or IE wrapper maybe? Just guessing…

Please try unblocking IE or Chrome and then try the app and see if it works, then you’ll know for sure.

If it’s a Chrome wrapper then it’s basically just Chrome using the network.


#6

Yes, the music app uses the browser.


#7

Hi Ken,

I assume it is using a broswer engine however I have Chrome, IE and Edge all allowed and still just get a blank page when “Ask to Connect” is enabled.

Have also confirmed it on a friends PC now too.

It works totally fine as soon as I change to “Click to Block”

Very strange.

Thanks


#8

I’ll report this to the team so we can try to reproduce this on our end.


#9

Thanks Ken, I appreciate the support.


#10

@hidyn Please change the name of the app to “Google Play Music Desktop Player.exe” and see if that helps.


#11

@Ken_GlassWire I can confirm that renaming “Google%20Play%20Music%20Desktop%20Player.exe” to “Google Play Music Desktop Player.exe” fixes the issue.

Thanks for all the help :slight_smile: