GW is Not Working on Windows 10 2004 Version (solved, host process was blocked inadvertently)

Dear Developer,

You Guys are Doing Amazing with the Apps. I was using GW in My Old Windows Perfectly. Then I Update My Windows to It’s Latest 2004 Version. But in this Version, GW is Not Working. Then I thought maybe I should Update the GW too. So I Updated it to ‘GlassWire Elite 2.2.210’. But Even Now I’m Facing the Same Problem. (Screenshot Attached)

Problem is When I Use GW as Click to Block Mode And Turned on the Little Firewall on Button in GW App, My Internet Connection Gone Block. I Can’t Access any other site then. Though Chrome is Unblocked.

I’ve tried all the basic Steps Like,

  1. Go to add/remove programs and uninstall GlassWire.
  2. Go to the Windows Firewall control panel and choose “restore defaults”. Yes, I see you did this already but please try a second time.
  3. Reboot
  4. Get our latest version and choose “reset firewall” and “clean install”.

Nothing Happened. Can You Tell me what’s Wrong?


Thanks for your kind words, and I am sorry to hear about this issue. Let me help you get it fixed.

I believe our entire team is using Windows 10 2004 now and we have not seen this issue.

I will ask you what I usually ask people who have a problem like this:

  1. What antivirus are you using? Does it use its own firewall that might disable the Windows Firewall API we use?

  2. Are you using another firewall application? Using two firewalls simultaneously can cause issues like this.


I see you are blocking the “host process”. Can you unblock that and see if it solves the issue?

Yes, It Works After Unblocking the Host Process. The host Process is Consuming too much Data. Why Can’t I Block it?

Currently I’m Not Using Any Antivirus or Any other Firewall Apps. Just Windows Defender as it is came as Default.

I’m glad Chrome is working now.

Some apps use the Windows Host Process to send some data. It’s how Windows functions and there isn’t anything we can do about it. It might be possible to use an alternative browser that doesn’t work this way.

There is More than One ‘Host Process’. Which one Should I Block?


You should not block the “Host Process” at all if you use Chrome because Chrome seems to be using the host process to send data.

Sorry if I wrote something incorrectly or in a confusing way. I thought the issue was solved if you unblocked the Host Process?


Absolutely. Thank you So much for your Help.

1 Like