GW Randomly Forgetting it Should be Maximized


#1

Seemingly randomly, upon opening the Glasswire GUI, it forgets that it had been maximized (using the Maximize button) when it was previously closed. It’s a little annoying never to know for sure how it will open. I have sometimes seen this in other GW versions, but I never saw it in 2.0.123. Now it’s back in 2.1.137.

Additionally, I tried testing it after I maximized GW by dragging the edges to maximum. After closing and reopening GW, the program opens horizontally maximized but there is some space between the top of GW and the top of the screen as well as some space between the bottom of GW and the bottom of the screen, requiring me to drag it to maximum again. I don’t know if it will help you but I have my main Windows task bar positioned across the top of my screen instead of the Windows default position (bottom of screen). Thank you for your help.


#2

Thanks.

We will try to reproduce this and solve it. I apologize for the issue.


#3

Hi Ken,
Thank you. It might help in reproducing the problem to know that I shut down both the computer and the network each night. And I shut down the computer alone, whenever I am going to be away from it for several hours.

Thanks again.
dfg


#4

Now that I am paying this issue more attention lately, I am finding that no matter whether I have previously maximized the Main GW screen or dragged the borders to maximum, it still starts up minimized about 90% of the time following a system shutdown. Does any kind of a reinstall solve this? Or any other action I can take? If the previous window size is stored in a cookie, I am preserving the glasswire.com cookie between startups. That seems to have no effect, however. Thanks for the help!


#5

After I mentioned a glasswire.com cookie in my previous message, I tried deleting that cookie and then clean reinstalling GW, saving my usage data. Since then, GW seems to be remembering it’s previous size and position again between startups. Do you think that cookie have really been the problem? Thanks.


#6

@csdfg2

Do you mean a GlassWire.com website cookie or something else?


#8

It was a cookie that existed among all my other website cookies. It might have been very old (a couple years maybe). I had previously been preserving that cookie during cleaning, thinking it was necessary for Glasswire. (There is also a forum.glasswire.com cookie which I also preserve.) But I tried deleting the glasswire.com cookie. GW seems to be remembering its previous state after I did that. Maybe there was a connection, maybe not. I also cleanly reinstalled GW. That might have also been the apparent fix.


#9

@csdfg2

Website cookies make no difference in GlassWire behavior, so I think it’s unrelated.


#11

That’s true. So, it probably was the clean reinstall that affected GW’s window size/position memory. Thank you.
dfg