GW Reverting to Small Window Again


#21

Hi Ken,
A few days ago, you mentioned I could try a test version. I never saw instructions how I could get the test version or else I missed it someplace. Is there a special link I should use? Or should I just go to the regular download link?

Thank you.
dfg


#22

@csdfg2

Our update is now live if you want to get it on our download page.


#23

@Ken_GlassWire So far the UI is staying were it should be so can you tell us if you found the issue and the fix was in the new build?

Thanks!


#24

@TripleHelix

We think we fixed it, but please let me know if we are mistaken. We had trouble recreating this issue.


#25

After a number of unremarkable start-ups since I installed the new version on Monday (with the maximize button set to “maximize”), today I tried maximizing the GW window by dragging the edges, then shut down the machine for a couple hours. Upon opening GW after starting back up, it was again located in the upper left as a small window. I am going to maximize again by using the maximize button and then shutting down and restarting and continuing on with life until I see the error again.


#26

Hi Ken, Still testing v2.1.140. So far the UI size and position has stayed in place. Note, it’s only day 3 for me with testing, and i know sometimes it can be a week before the problem might reoccur. I will re post after a week or so, to let you know my results.


#27

@csdfg2

Please email us with a link to this thread. I have an even newer version to test with more detailed logs if you’d like to try it.


#29

Thank you. Email sent.


#30

@Ken_GlassWire first time I just booted up and opened GW UI and it was in the Top left corner again. Version 2.1.140 Also I don’t use the Maximize button.

I will send you an email to get the newer test build.


#31

I had an interesting thing happen tonight that might possibly shed some light on the GW window size-position issue. My email program (Thunderbird 63) started unexpectedly to not allow me to adjust the main window size or position when not using the Maximize button (similar to GW’s main window). After researching the TB problem, I disabled the last TB addon that I had installed two days ago (“HTML Mode” button). That seems to have fixed the TB problem. As well, the GW window size-position seems to have become more stable since I disabled that TB addon. Could there be some interaction between the two programs concerning their display settings or function, especially if the disabled TB addon was broken? Maybe other programs similarly play havoc with display settings. Just a thought.


#32

Do you mean Thunderbird 60.3?

I’m not familiar with the add-on you mention but it is possible that this is an out of date XUL-based add-on. It probably should have been updated to remain compatible with Thunderbird 60.

I can’t see how Thunderbird could interfere with GlassWire unless the add-on was also developed with the Qt library that GlassWire is built with.


#33

Yes, TB 60.3.3 (latest). Sorry about the ambiguity. The addon I mentioned (the HTML Mode button) is one of the individual codefisher.org Taskbar Button Pack buttons that I had to install as an individual addon because the popular combined Button Pack addon stopped working with the new TB version. Disabling the individual HTML Mode addon button seemed to allow the GW window position-size to become more stable which seemed to suggest some sort of interaction between them.


#34

I personally don’t use Thunderbird and I use Office 2019 in which has Outlook 2019 but IMO I have only seen it once on 2.1.140 and all my other programs and apps work fine so it must be a Glasswire issue.


#35

After several days of no issues, GW opened this morning as a small window in the upper left of the screen. I zipped the glasswire.log file and sent to the “help” email address.


#36

I got it, thank you!