Halo : MCC (Reach)

When you launch reach with glasswire firewall enabled, it boots you to the store as it fails to check the licence. It somehow doesnt even work with click to block…

Welcome aboard Halo!

Thanks :slight_smile:
Is anyone else having this issue?
Any logs I can provide?
Should I upload a video to help diagnose?

1 Like

@hintonian

You are in Click to block and your game will not work at all? If you turn our firewall to “Off” does it still not work?

in both ‘click to block’ and ‘ask to connect’ it doesn’t work :frowning:
when I turn it off (via both windows and glasswire firewall panel) it works fine.
This doesn’t seem like a great idea to keep using, hence me posting here to see if anyone knows anything?
I tired adding ports manually to the windows firewall rules and tried re adding the apps to the allowed list but no change.

@hintonian

That’s really weird! Have you ever used any other firewall software? I ask because I may have another thing I can suggest.

I don’t know how our “click to block” mode could block this app.

Is it possible the app network activity goes through another app, for example something like the Steam app?

I have previously, but there is nothing other than Glasswire on my system currently.

it is weird and I think your theory of it launching another app is correct as it appears to check the licence through windows store and then close itself.

I don’t have the steam copy (which may be unaffected, hence the low report count), I have the windows store version.

I did find someone else mentioning it on ‘halowaypoint’ under the name of ‘EmberDragon’ - (halowaypoint/en-us/forums/f3681fbc78fa43878c4aec9a63a46224/topics/halo-mcc-reach-not-launching-windows-store-fix/31775edb-86c8-4e07-b189-cab6eaf73644/posts?page=2#post31)
but no follow up.

I’m happy to record a short video / step by step guide if it helps?

Welcome Aboard hintonian !

Welcome Aboard the Welcome Aboard train.

ok, so i’m confused as to the welcome aboards (especially seeing as its already been done) - are people just bumping their post count? is this another useless forum? -_-
Can I do something else to help my issue, like run wireshark or something?
or do I just give up and un-install glasswire?

@hintonian

When you are on “Click to block” and the game is still blocked, what all is blocked there? Nothing, or could you give me a list? Feel free to message me privately by clicking my icon here.

You could also send me a private screenshot of your GlassWire firewall tab.

I’m bemused too.
Even getting one welcome aboard is unusual so getting three including two from one user is very rare.

You’re getting them in this topic because this is where your first post/topic was created. Discourse displays a message letting people know because it generally helps people to be a little kinder and more helpful. Here’s yours:

This is the first time hintonian has posted — let’s welcome them to our community!

The number of posts you make has no influence on anything in Discourse. Liked posts (with a :heart:) are a different matter because they do contribute to earning your badges.

Some users are just particularly friendly.

What, like Reddit?

The only useless forums I’ve seen are clone sites which have scraped other real forums to get free content to boost their SEO and ad income.

By the way, you can use emojis here. Just type a colon after a space and the emoji picker should appear e.g. :expressionless: for -_-

1 Like

@Remah:
thanks for the info and responses, sorry for the negativity :slight_smile:
:rofl: at the reddit joke!

@Ken_GlassWire:
Just re-tested it with ‘click to block’ enabled and it appears to work fine, only broken in ‘Ask to connect’ mode now - maybe it was still swapping when tested previously.

I had removed all apps from the ‘Blocked Apps’ section and now removed all of them again to re-test. Same progress, in ‘Ask to connect’ mode - the game starts then crashes to Microsoft store as if failing a licence check.

I’d really like to remain in ‘Ask to connect’ mode if possible - could you potentially show how to find the licence check part of the game?

1 Like

@Ken_GlassWire: I forgot to add to the end - please :slight_smile:

@hintonian

When you are in “Click to block” what all is blocked, if anything? I was hoping you could determine what’s blocked in “Ask to connect” then create a new profile and unblock it so you can stay in “Ask to connect” mode all the time.

Or, you could just switch modes when playing that game if you can’t figure out what should be unblocked.

Sorry for the issue. We will investigate and try to recreate it.