High CPU usage with Discord running

Recently, I have been running Discord in the background while gaming, and noticed annoying frame stutters with a non-demanding game on an overclocked CPU that sure shouldn’t have stuttered: when i looked at the task manager, I saw that the GW control service was using around 35-40% of the CPU, which sounded really strange because eventhough the game is an online multiplayer I’d never had issues like that before. I tried to restart the service, only to have the same issue again and then I tried to close Discord, which I noticed solved the problem. The thing is that I have already read many forum and Reddit threads on the problem, and they all seemed to agree on the cause being a faulty install of the program or a big amount of host contacted constantly (like when transferring via p2p, which causes no issues on my PC btw), but in this case Discord doesn’t actually contact many hosts at all, in fact most of the time (with Discord only running) the graph shows 0B of transferred data, or at most 400/500B transfers from Discord to a single host… Is there a way to blacklist Discord from being picked up by GW, or any way to solve the issue? It’s really deal-breaking for me. If not, at least you’re aware of the issue and I hope you’ll be able to work on a fix

1 Like

@LionSpeck

We have never had this reported before that I recall. Discourse is a popular software so I think I’d remember.

If you switch to our “Incognito” mode does it make any difference? If you switch to “Click to block” mode with the firewall, does it make any difference?

If you uninstall GlassWire, reboot, then reinstall our software using our “clean install” option does it solve it for you?

When this is happening if you look at GlassWire’s live graph does it show any other unusual activity from other apps (not Discord)? If so try analyzing them with the VirusTotal option.

And of course, GlassWire can show you what apps are slowing down your PCs Internet connection in real-time. Download GlassWire here to try it for free!

Ok, so firstly the firewall is taken care of by Kaspersky, so GW doesn’t influence that, and also it’s the free version, so I wouldn’t be able to change the firewall mode anyway; secondly, by enabling incognito mode, surprisingly to me the issue persists; also, reinstalling and resetting GW’s options didn’t solve the problem. As for the graph, there’s absolutely nothing suspicious or abnormal registered

@LionSpeck

Can you tell me the game that you are playing with Discord/GlassWire? It will help us try to reproduce the problem. Thank you.

Sure, it’s Heroes of the Storm. I also noticed that if the game is closed, it may still cause high CPU usage

Ok, I found the cause of the problem! It was a Discord plugin that displayed the current latency to the connected voice server; as soon as I disabled it and restarted Discord, the high CPU usage of the GW Control Service was gone. Thanks anyways for the help, I won’t be keeping the plugin on anyways, so it isn’t going to be an issue for me. I’ll post here the plugin link if you want to test out why it causes the issue:


and of course it needs https://betterdiscord.net/ as the plugin loader

1 Like