Incognito Apps Missing Names

Hi, I have just wanted to add an app to the incognito apps list where I’ve already added several apps before (it’s been some time since I’ve added the last one) and for some reason when I open the list from the menu all I see is numbers, no app names, no app icons :confused:
Is it a bug? Is there a way to refresh the names?
Thanks

@Y4niv

Did you add these apps previously as names, and they changed to numbers? Or have you never used Incognito and now you see these numbers here? I want to be sure I understand.

Hi Ken, yes I’ve added each app individually and they all had names and icons (I don’t use the fully incognito mode), I’ve added Chrome now and it is the only one with name and icon:

It might have happened after one of the latest updates but I can’t be sure as I don’t look at the list too often :slight_smile:

@Y4niv

I have not asked our team yet for clues, but I have a theory. Did you recently switch drive names or make any changes to your HD or anything like that? Maybe some hardware was changed and it caused this weird bug?

@Ken_GlassWire

I did not switch drive names or did any changes to my hard drives, the only thing related to HD is that couple of months ago I’ve connected my external HDD to the PC (through one of the USB ports) and it’s been connected since then, but it does not host any GlassWire files from what I know, I just use it for backups and such :slight_smile:
The last changes were cloning my HDD drive into a new SSD drive (everything stayed the same) and adding a bluray drive, both was about 1.5~2 years ago, it might be related? but I’m pretty sure I’ve added at least one app to the list since then (is there a way to check when the apps were added?), let me know if you need any more information, thanks!

1 Like

Very strange! I will ask our team and I’ll let you know what they say. I’ve never seen this issue before. Thanks for your report and sorry for the problem.

1 Like

@Y4niv

We were unable to recreate this issue.

Our team asked what happens if you re-add back the Incognito apps. Are they still numbers or what happens?

@Ken_GlassWire

Okay so I’ve added two applications that I remember adding before, they have been added successfully again with their name and icon, but the numbers that were there before stayed so the 2 new apps did not replace the existing numbers.

By looking at the graph I think I can see that before adding them to the incognito, GlasWire was really logging these apps like they are not in that list and after adding them the logging stopped, so all of the apps I’ve already added might need to be added again and I can discard all of the existing numebrs :confused:

2 Likes

We were able to find this bug, thanks for your report! Our next coming update won’t have the fix but the next release after should have it.

1 Like

Thanks @Ken_GlassWire! Keep up the great work! :clap: :smiley:

1 Like

We were able to find this bug, thanks for your report! Our next coming update won’t have the fix but the next release after should have it.

Hi @Ken_GlassWire, does the new version 2.3.321 fixed this issue?

@Y4niv

I’m not sure, did you get a chance to upgrade yet? I will check out tickets and see if I can find out.

I’ll install it tomorrow probably, but I’m not sure I’ll be able to tell right away if this has been fixed, I’d love to know what you found, thanks! :slight_smile:

1 Like