It looks as though GW blocks Windows Update

I’m new to GW and have been trying to come to grips with its features, some of them are a steep learning curve for tech novice like myself. As I move around I’m getting to understand much - although there’s much more I don’t.
FWIW, I’m trying to find a replacement for ZoneAlarm which I’d been using for over a decade but have found their new generation not very useful. So far, GW looks like the No 1 candidate as long as I can find my way out of inexplicable dead ends like the following:
For example, my access to Windows Update is not working, I get a message saying unable to contact the Server. This has only appeared since installing GW, so it looks like ther’s something GW is doing that I don’t know how to stop.
Any guidance will be much appreciated.

1 Like

Hi geoffwhere
Best to try a few things, to see if it is in fact GW is blocking windows updating.

Try turning off GW firewall and then see if windows update works.

After that you could try uninstall GW, Reboot the computer, then do a fresh install and select options Restore Windows Firewall Default Settings.
Also select Clean Install (Clear Data & Settings)
After installing i always like to Reboot the PC again,
"Old school habbit, amongst other reasons "

This may help, see screenshot below…

GW Install Choose Options

Thanks for your advice & help, much appreciated. I tried your suggestions, no luck. A Google search on the Windows Update error brought me to doing a medley of scf /scannow and dism routines. SFC found some corrupt files and dism fixed them all, but still no success with running update.
So, as of this moment, I can’t run Windows Update. Probably unrelated, I’m also unable to reinstall WhatsApp for Windows from Microsot Store - fails the download and install.
Whether all these are related or not, don’t know, but the plot thickens.

Hi geoffwhere
Maybe try this Windows Update Troubleshooter

Or you can Update by installing updates manually

I know there are tools to fix windows update.
Be very careful where you might find such tools, some can have other unwanted programs or malware.

Thanks for your ongoing interest and assistance. FYI, I had online contact with Microsoft and they advised me to reinstall Windows (fresh download ISO), which I have completed, but the same problem exists. I suspect I’m victim of a buggy Windows 2H23 update.

This is technically not possible for GlassWire to block Windows Updates. Since GW uses the Microsoft Defender APIs and all, Microsoft has built in protections to keep their servers and such from being blocked, even in the hosts file. It makes sure that Windows can still work and get trusted updates without interference from malware/rootkits, etc.

23H2 is not out yet, either - assuming this is Windows 11. I have not seen anything in the thread specifying which you’re running and want to repair.

I’d be interesting in seeing the error codes you’re seeing.

I believe it would be worthwhile to get my Anti-Malware Toolkit.

A few things I would recommend doing once you install it (you can also follow my Lunarsoft PC Cleanup guide):

  • Download AdwCleaner and Malwarebytes Full
  • With AdwCleaner, go to Settings and enable all the Delete/Reset settings. (the aforementioned wiki has screenshots of settings to enable too)
  • After scanning and fixing all issues found with Adw and Malwarebytes, reboot as the programs prompt.
  • After rebooting from using both apps, reopen the Anti-Malware Toolkit, go under Tasks.
  • In Tasks, you will want to run DISM & SFC, it will run the DISM repairs and then scan again with SFC.
  • Again in Tasks, run the Fix Windows Update, this will stop services relating to Windows Update, clear out the downloaded files/cache for updates, then restart the services.
  • Reboot and try to get updates again.
1 Like

No, it’s W10.
Thanks for your other suggestions which I will pursue tomorrow.

If your computer supports it, it may be worth upgrading to Windows 11 as well. You can use the PC Health Check app download in the Anti-Malware Toolkit, and there’s ways to make bootable USBs for 11 too.

i’m here to say thank you for this suggestion

Tried all that, and more (from other pundits) without success. I’ve also tried disabling all antivirus and firewall software (e.g. glassware, Microsoft, Malwarebytes and the remnants of ZoneAlarm - in the form of disabling 2 orphan services - and get to the point where windows update tells me it’s downloading an update but the counter sits on 0% and goes no further.
I’m getting to the stage of thinking about tearing my hair out, what’s left of it!

It’s Windows 10, I hope you get it.

Try running through the directions I provided once more, then at the end reboot, then shutdown.

If this still does not resolve the issue I would recommend doing an OS repair install over top of the existing OS. Or, try and upgrade to Windows 11.

Not having any luck. This time through, the DISM tool is stalling at 62.3%
I’ll leave it to run out and, instead of following with the SFC tool, I’ll run the Windows Repair. Suspect the SSD System Drive is the problem.
Unless you have any other recommendation.
Fingers crossed.

Check using the manufacturer’s software. WD/Sandisk, Samsung, and several of those companies all have their own special software to check for errors and update firmware if necessary.

If you run a chkdsk on the drive, what comes back?

There are a few possible reasons why you are unable to contact the Windows Update server after installing GW. Here are a few things you can try to troubleshoot the issue:

  • Check your internet connection
  • Check your firewall settings
  • Reset your Windows Update components
  1. Open Command Prompt as administrator.
  2. Type the following commands, pressing Enter after each one:

net stop wuauserv net stop cryptSvc net stop bits net stop msiserver ren C:\Windows\SoftwareDistribution SoftwareDistribution.old ren C:\Windows\System32\catroot2 catroot2.old net start wuauserv net start cryptSvc net start bits net start msiserver

  1. Restart your computer.

Once you have restarted your computer, try to check for Windows updates again. If you are still unable to connect to the server, you may need to contact GW support for further assistance.

geoffwhere has already done all of those things.

Also, so you know, AMT’s Fix Windows Update runs those commands automatically for the user when the option is selected.

The problem isn’t Glasswire, it’s a problem with his Windows install. I advised him in another thread to do an in place upgrade, or to upgrade to Windows 11.

I’ve just discovered that the Windows Update problem is but one of several. I’ve previously mentioned Microsoft Store failing to download and install owned Apps. I’ve just discovered that both Malwarebytes Windows Firewall Control app (V 6.9.8 running on Windows Server) refuses to update to V 6.9.9).
Also Plex Server (on the Windows Server) same problem with downloading update.
So it appears that some parameter has been set that prevents apps from downloading their update files.

Boot to Safe Mode (with Networking) and see if you can run updaters for any of those apps. Can also try and use my Anti-Malware Toolkit to see if it’s update check works before and after safe mode.

I spent several hours yesterday in an online chat session with a Microsoft support tech which got us to the point of surrendering to doing the full Windows re-install, something I’ve dreaded and been avoiding because of the follow-on remedial work to recover the system to its original operational status.
During that session, Microsoft was unable to determine why the Windows setup download remained stuck on 0% (the same as has been happening in Windows Update and other Apps), so they left me with the task of doing what I didn’t want to do but which was now a necessary evil, as nothing else was working. So, this morning I started the process of downloading Windows 10 installation media.
Again, no go. Just as with the ‘Update Now’ option, the download process stalled at 0%.
So, I thought I’d try it on my Windows Server PC – same outcome, leading me to suspect some gremlin/s may still be lurking from my experiments with candidates for replacement Antivirus/Firewall software. Thinking out of the box, I decided to enlist my wife’s Windows notebook to do the download – same error, 0%.
That got me thinking that, while previously applying one of the solutions from a forum site, perhaps because it had suggested changing my PC Region to my country of residence rather than the country where the Windows was initially installed, and because my wife’s notebook is set to the same region, that could be the reason the updates weren’t downloading. So I went back to my PC and started the VPN and set it to the original region.
All updates downloaded and installed. Sheesh! Microsoft seems to have a habit of making some tasks way more complex and difficult than necessary. Who’d have thought a region setting would prevent Windows (and other updates) from downloading?
Anyway, On with the show. Now that I know what’s been holding me back I should be able to clean up this mess until Microsoft throws more broken glass on the pathway.


Thank you for sharing that info so others may know how to fix the problem also. :grinning: