Loading Glasswire 2_3_321 doesn't run service

Hi Ken,
I had to unload Glasswire with both release 2_3_321 and 2_3_318. They both produced dump files and could not start the Glasswire service that was the cause.
I am using Windows 10 Pro 64bit 20H2 with 32GB of memory.
I had one bluescreen after loading, but that may have been a fluke. But I haven’t had one for years, i.e. I stayed away from Windows 10 until Jan 2021;^)
I have all my computers currently on Windows 10 Pro 64bit 20H2 with various processors and memory sizes. So hopefully a fix on one does all!
What should I do next? I did try uninstalling GW, rebooting, and reloading. No change.

Regards,
Speedy

@Speedy

Sorry for the issue. If you check the “clean install” option, does it solve it?

Does this help?

Why can’t GlassWire connect to its local server and why won’t GlassWire’s graph load?

GlassWire for Windows has a local Windows service that runs locally on your PC. This Windows service keeps track of your network activity for your PC or server. If that Windows service cannot start then GlassWire cannot graph your data usage.

Please note your graph data never leaves your PC, and we at GlassWire cannot ever access that data since it’s only stored locally on your own PC or server. Our privacy policy explains how we can’t ever see your data.

If you are experiencing this problem first try rebooting your PC. If GlassWire still cannot run please uninstall GlassWire in add/remove programs, then reboot your PC (this is an important step in the process), then reinstall GlassWire while checking its “clean install” option in its installer. You can download our latest software from our download page.

If GlassWire’s graph will still not load please check to see if the following Windows services are running in the Windows task manager:

  • WlanSvc (WLan AutoConfig)
  • BFE (Base Filtering Engine)
  • EventLog (Windows Event Log)

These Windows services are usually on by default unless you disabled them. If you find these services are running but GlassWire will still not run please consider running Windows Update. With very old versions of Windows GlassWire may not run properly. After updating your device please once again try a clean install with GlassWire in the order listed above.

If neither of those things help please let me know. Please keep the .dmp file if the issue continues even with a clean install. We may ask you to email it to us using a cloud service like Google Drive.

If the suggestions above don’t help, please email me Contact GlassWire with a link to this thread so I can help you try some other options. @Speedy

I forgot to mention that 2.3.323 was released yesterday, so please be sure you are using that version to test.

Hi Ken,
Thanks for quick response. I have loaded 2.3.323 with clean install option. Services are running and all appears normal. I’ll have to revisit some settings and send another message to confirm successful update.
Thanks Again,
Speedy

1 Like

It is most likely your GlassWire database became corrupted somehow. Sorry for the issue and thanks for using GlassWire.

Glasswire 2.3.323 was running working well until I loaded KB5004945. Now Glasswire service starts with Windows 10 and stops a few seconds later. This happened immediately after MS update fix and continues to present. What did this break?

@Speedy

I am running KB5004945 and I cannot recreate this. It must be a coincidence I think?

If you install our latest version with “clean install” checked does it solve it? How much memory does your PC have?

Hi Ken,

I forgot to mention that I had a bluescreen after update and the KB made a change to ndis.sys, which was the module Windows 10 dump said had caused the BS. Anyway, is 2.3.323 the latest release?

Thanks,
Speedy

@Speedy

Yes, our latest release is 2.3.323. Download Firewall Software by GlassWire Did you see a .dmp file on your desktop after the crash? If not then it most likely was not GlassWire. GlassWire should leave a .dmp on your desktop if it crashes.

Hi Ken,
I have many .dmp files for today and yesterday. How do I get them to you or what should I do with them?
Speedy

If the .dmp is from our latest version 2.3.323 please email them to us using Google Drive, or another cloud service. Our email addresses are here: Contact GlassWire

If the .dmp is from an older version, please don’t send the .dmp and upgrade to our latest version.

Please include a link to this forum post so I know it’s you. Thanks!

Hi Ken,

I had sent a .dmp link your way yesterday. I have several .dmp files for GW 2.3.323 during the dates 7/7, 7/8, 7/9. What is strange is that it has started working 7/10 and 7/11. Previously it failed without exception, but now it works consistently. I hope the .dmp helps with this issue. Perhaps you need some other .dmp, no problem - I have not deleted any.

Thanks,
Speedy

Thanks! I am pretty sure I replied to your email. We’ll investigate the .dmp.

I’m glad GlassWire started working.