Messing DNS and huge conflict with NordVPN


I am using Glasswire and NordVPN and since few weeks ago I was unable to succesfully run NordVPN on Windows10. I found out some app must mess DNS settings and it makes NordVPN unable to reach their DNS servers so browsing is unavaible as any request ends as time out. I found out even I change my adapters settings to auto DNS it is always changed manually to fixed DNS IPs. So I started to kill one app by one and ended with Glasswire. If I exit Glasswire there still some processes in the memory, after killing the monitor and another processor finally nothing messed with DNS settings.

So I tried on different machine with Win10 and Glasswire installed and started to take Glasswire firewall off etc. but nothing helped, so unistall and the problem is gone.

So seems Glasswire is somehow messing DNS servers and make big conflict with NordVPN. I would like to return to use of Glasswire so is there a solution how to solve this problem?

Thank you.



GlassWire makes no changes to Windows DNS and has no ability to do so. Could it have been a coincidence? Lots of our users use VPN with no problems, including me.

Update: This problem is solved: Messing DNS and huge conflict with NordVPN


It is quite common for VPN setups to have this sort of problem. I’d be surprised if it is GlassWire causing the problem so can you clarify your setup and what has happened?

Do you mean that you used both together and NordVPN was working but a problem developed and it has not worked since?

GlassWire shouldn’t be causing the problem, particularly if you turned off the GlassWire firewall function.

How is NordVPN set up - are you using their software or one of the other protocols?
Are you running it on your computer or on your router (e.g. using DD-WRT)?
IPv4 or IPv6? And what is the IP address for the DNS server with GlassWire running and without GlassWire running?


I would really like to believe it is not Glasswire problem but the only solution which worked was to uninstall Glasswire. I do it in my free time and to be honest I spent lot of hours to fixing it so I would appreciate if anybody else could go with this problem because i do not have so much free time.

I am using NordVPN for more than a year without many problems on many devices (landroid, win7, win10). About two weeks ago started my problems to connect on Windows 10 machines ( other machines without a problem). I am not sure about the date but I figured out that the only main changes I made were Glasswire update and NordVPN update. So I blamed NordVPN for sure and contacted their tech support. We found DNS problem as when I looked at adapter settings there were set fixed DNS IPs. When I changed it to auto it remained till I used NordVPN app and connected to any server. Then after few moments when I checked adapter settings there were again the fixed IPs of DNS even Glasswire didnt noticed the change. Normally Glasswire notifies when new DNS is set and it happened Glasswire showed it but not everytime. Then I set adapters DNS settings to auto again, flushed DNS via command line and I was able to browse about 5 sec then again DNS were changed or etc. and I was unable to browse again. So I killed Glasswire (exit app) but still the problem perstisted. So I open system manager and looked at running processes and even Glasswire was closed I found out 2 running processors for Glasswire - monitor and one more. When I killed them , set auto DNS, flushed DNS I was able to browse without any problems. To prove it I have another machine with Win10 and Glasswire and this machine has almost no other apps and there was also the problem. I uninstalled Glasswire,restarted and the problem was solved.

I am really sorry about details like I said I have limited free time, I will try install Glasswire back on my 2nd machine and try to go step by step and document it to be precise because some details I do not remeber I spent with it till early morning.

I use NordVPN as installed app (when trying to fix the problem I used about 4 different versions, I was even provided by new beta from NordVPN), UDP protocol, IP4, DNS with VPN on -,
I am using Windows 10 Home.

If you can provide downgrade of Glasswire like version 1.2.73 or even earlier I would test it.


Thanks for that info.

The most useful information is the IP addresses for the DNS settings that caused your problem. So when the problem occurs please record those addresses. They may indicate who or what is causing your problem.


The DNS name server settings are stored in the Windows registry and there are various means to monitor specific programs or specific registry keys.

I’ve listed two methods below. I haven’t found any issues with my GlassWire install so make sure that you download the latest version 1.2.74 from GlassWire.

Registry auditing
Windows has auditing features to allow you to monitor a specific registry key to see what program is setting the value. The following article gives an example:

The DNS server IP addresses on my system are stored in the following registry key under the name “NameServer”. So if I monitor this key I can see what is changing them:

You might also have to check your DHCP settings when you have the problem because they might have changed and automatically assigned the new DNS server addresses. In the registry, the default is stored under this key with the name “DhcpNameServer”. You can compare the default with your adapter/interface specific settings:

Process Monitor
You can also use Microsoft SysInternals Process Monitor to monitor all registry changes made by GlassWire if you are sure that GlassWire is making the changes. The article above showed this method but here’s a more detailed article on how to use Process Monitor to monitor a program to see if it is changing any or one specific registry key:


Hello. I will try SysInterlas and register later as need to study it first or please read my post if you can come up with better solutin now.

Without Glasswire I was able to use NordVPN without any problems for the past 2 days (since the uninstall). So i tried to install Glasswire back. I installed the newest version (1.2.74).

My adaptors settings - PICTURE 1_

1)Installation OK, restarted machine (Win 10, ver 1607)
2) After restart I ran NordVPN.exe and made a connection to one of the servers. I tried to browse sites and any http request ended as time out. I tried to flush DNS, change DNS to auto, connect to different server, time out problems at all tries
3) I exited Glasswire. I tried again to flush DNS, auto DNS, reconnect NordVPN, still the time out problem and no able to browse any page (Of course I tried also different browsers + I already uninstalled antivur + firewall to be sure nothing could block NordVPN). Even the Glasswire exited there were still running 2 process - Glasswire Control Service and Glasswire Computer Idle Monitor. PICTURE 2_

  1. I was still connected to NordVPN, went to adaptor settings, set DNS to auto, opened cmd and flushed DNS. I tried to ping google but it was still unable but I noticed NordVPN was trying to reconnect (probably after flushed DNS). So I waited as NordVPN reconnected. Then I tried to ping google and i was succesfull. I opened browser and the problem was solved and I was able to browse without any problem while connected on NordVPN - PICTURE 3_

  2. To prove the Glasswire conflict I wanted to run it again and try to browse while Glasswire is back on. Hmm, I couldnt get Glasswire working. Glasswire showed the service is stopped and needs to restart. I pressed restart and Glasswire was trying to reconnect but was unable (Attempting connection (1), then Attempting connection (2) etc.) again ended as service stopped running and needs to be restarted. Simply I was not able to rerun it and the only solution was to restart Windows. Still I was connected to NordVPN and avaible to ping google or browse without any problems. - PICTURE_4 + PICTURE_5

  3. After the restart we are back at 1) as I cant’t use Glasswire If I want to use NordVPN.

So it really seems Glasswire somehow blocks NordVPN, especially the monitor process and then after I exit Glasswire and kill its processes and try to run it bakc it isnt able to reconnect and work again until the whole system is restarted. After uninstall of Glasswire problems with NordVPN dissapear and I am able to use NordVPN.

So what now please? Should I make the registry monitoring as suggested from Remah or try something different after I posted this new info. I really do not want to spend another hours just finally figure there is the problem with Glasswire from the start.

Btw. after I wrote it all I was ******** as I got notification I can put just 1 image to the post as a new user … please do something with this rule I am trying to help somehow and this just makes me to leave it and rather do nothing as my current solution is clear, not using Glasswire, on the other hand I thought to buy a pro version but seems the tech support is selfdo, why to pay money then? Sorry seems I am overworked and tired. Still I am interested about this problem and its solution (well not the uninstall and goodbye Glasswire solution).

So please all images are here:


@paddy, as I said before. It would be really useful to know the IP addresses when the problem occurs:

Even better if you show the results of the command:

ipconfig /all


@paddy, I’m up and running on NordVPN without any problem on a three-day trial. So far the service has been very good: fast response to online chat, easy to use, local servers.

There is something on your system that I don’t have on mine. That is why I was encouraging you to show your connection settings when you have the problem. The DNS server IP addresses may well be on a blacklist somewhere.


@Ken_GlassWire, @paddy has asked what you want him to do. Have you confirmed that GlassWire doesn’t make an API call that might cause this? Anyway, I’ve bolded his comments below.

@paddy, the tech support is not self do although I know I also get frustrated having to assemble evidence and research the issue so it is clear that GlassWire has a problem:

  • The problem is unusual. Problems like this are difficult to resolve when it is not clear what the mechanism is that is causing the problem. For a start, you might be the only NordVPN and GlassWire user. But if there are others then why haven’t they reported the problem? I’m now a NordVPN user and I can’t reproduce the problem so that suggests it is not directly caused by GlassWire.
  • GlassWire support will be bemused by this issue. The behavior causing the problem is outside the bounds that the GlassWire developers are working within. GlassWire does not intend to change DNS servers and the developers can easily confirm that they never use such an API feature.
  • It is difficult to believe that GlassWire would deliberately cause this problem which is much more characteristic of malware.

I trust your evidence but I don’t think that your interpretation is correct. I believe that the problem is linked to GlassWire but only indirectly. Something else is the real source of your issue. That’s why I suggested two approaches to identify what is changing your network settings: registry auditing to identify what is changing your DNS server settings and process monitoring to eliminate GlassWire as the source.


FYI, @paddy, the reason I am getting so involved is to help you. The nature of your problem is difficult for anyone to help with until you can identify the source of your problem and confirm that is is or is not a GlassWire support issue.


@Paddy, I assume you know that Remah is a private user of Glasswire. His only interest is in understanding your problem and possibly helping to resolve it. He attempted to duplicate your installation and found not problems running with Glasswire. The implication is that there is a problem in your installation or use. It does not imply a problem with Glasswire.

I am also simply a private user. If you can provide the info Remah requests, perhaps he or the Glasswire support team may be able to help get you going with Glasswire. All problems point to your computer installation, not to Glasswire.


@richlife69 I believe you tagged the wrong person :stuck_out_tongue:


Sheesh! Thanks! :slight_smile: You know – there’s just so many Paddys in the world today… :smiley:


I understand the focus on the VPN and other factors in trying to understand the mysterious changes to DNS settings. I haven’t waded through this thread in any detail, and may be off base as a result, but felt it might be useful to point out that altering DNS settings is a common behavior of certain malware. It would be interesting to know what the “fixed ip” address is that is cropping up for DNS. You may very well be getting hijacked. Combine this with the various CA’s failures in maintaining a secure certificate system, and you could have a very scary scenario involving DNS redirection, legitimate appearing (to you and your browser) rouge certificates and very nasty MITM attacks. More likely though are the usual fare of botnet recruitment, ad insertion, and general messing with your system.

Just thought I’d give you something to keep you up at night ; ) Good Luck !


Hi there! I also use NordVPN and am experiencing the same problem. It is certainly Glasswire as I just went through a fresh upgrade from Win7 to Win10 and the problem began for me again immediately after installing Glasswire back on the system. It is not only with the NordVPN app but also OpenVPN and PPTP configs for Windows. It does work briefly when the connection is established, but ceases shortly thereafter. It doesn’t appear to be the firewall portion of the product as disabling the firewall does not help. Personally I’m glad to not be alone on this one!

Note: This problem will not occur until a reboot of the system after installing Glasswire. I will post any solutions I find!


The funny thing is, this wasn’t an issue until I purchased Glasswire and updated it. <----------- :frowning:


Hey Ken I would be glad to help diagnose the cause. They aren’t alone on this issue.


Good to hear it is common to the configurations. I wonder why I never got the problem - maybe because I didn’t do an install or activation of GlassWire.

So what are the DNS configurations changing to?


After reflecting on this, it is affecting OpenVPN and PPTP configurations then why aren’t there more posts from more affected users on other VPNs?