Monitoring activity on a remote server

Hello Forum,

I have GWPro 1.2.79 running nicely on my Win7.
It monitors my local network, local PC and other connected devices without any issues.
Recently I read that GW can also be used to monitor the traffic to and from a remote website.
I have a remote, test site which I’d like GW to monitor, it’s: IP:
I tried repeatedly to set this up but GW always fails after trying a few times, it can’t connect.
It’s not a remote server security exclusion issue because I can FTP the above site with my local PC.
It’s not a password issue either because I the password to FTP the remote site all the time.
I then read the previous forum posts on the same of similar subjects but without luck.
One the posts suggests the below steps which I tried without luck:

Local PC (the PC from which we are going to connect to the remote PC from):

  1. Open Settings\Client\Remote server;
  2. Click “Add new server” and select it on the “Server list”;
  3. Type the name of the server:
  4. Type the IP address of the remote server; Go to www.whatismyip.com51 from the remote server if you’re not sure
  5. Type the remote server password
  6. Check "Enable connection
  7. Click OK.The connection process should start.

What have I note done or what could I be doing wrong?
Thanks for any help.

Paul > Melbourne > Oz


Is it possible to upgrade both client versions to our latest one? You are using an old version.

If you disable the firewall temporarily on the remote PC does it work?

Try setting a blank password temporarily and see if it helps.

Is port forwarding set up on your router?

Try a service like ngrok to see if it allows the connection, and if it does not then there is a NAT problem where you need to work on your port forwarding. is another similar service.

Hi Ken_GlassWire.
Thank you for your reply, and I’ve updated to V.1.2.88.
I cannot disable the firewall on my remote server, my site Host won’t allow that, for obvious reasons.
Also I’m not trying to connect to a remote PC but a server which hosts a site and which I normally connect via FTP only.
Also I cannot set or change the password, it’s inactive or greyed out, see screenshot

I’m obviously doing something wrong if I can’t even edit the GW Remote Server settings.
Is there a step-by-step guide or URL for this that I can visit?


Is it possible to uninstall GlassWire remotely, then reinstall it using the “clean” install option and see if it allows you to change the password?

Hi Ken,
Done that, still the same issue and still can’t change the password, all greyed out.
Note that I installed and reinstalled GW locally, not remotely.
May be I should contact GW Tech Support?


I will ask the team if they have some ideas. Sorry for the problem.


If you click the dots in the password field you cannot delete it? What happens when you click those dots? It’s grey, but it can be clicked.


Sorry for the confusion.
You need to open a port on your remote server/PC. The GlassWire service uses the 7010 port by default, so please ask your ISP if they can open that port for GlassWire, then try again.

When inserting the IP include :7010 behind the IP.