My newly installed Glasswire starts and then disappears

Every time I start it a .dmp file appears after it starts for 1 or 2 seconds.

I cannot enter my subscription number because nothing appears.

What now?


I’m very sorry about that issue. That sounds very frustrating!

Please try the following:

  1. Go to add/remove programs and uninstall GlassWire.
  2. Reboot
  3. Reinstall our latest version and choose “clean install”.

Did it solve it?

If not, what OS do you have? Is it possible to run Windows Update?
What other security software do you use? Is it possible something is stopping our Windows service from running somehow?

I have uninstalled it a couple of times and reinstalled using “clean install”.
I have been using the version of GlassWire that I had downloaded on 14 February 2021 after I had paid for a subscription. I had no problems with it and used it with my KeepSolid VPN Unlimited and that worked up till yesterday when my computer lost its electricity. So I removed the VPN and Glasswire using REVO uninstall program because they would not work, among others. I reinstalled both the programs but only the VPN works. It gives an error message:- .dmp file which I cannot open. The answer must be in that file. I have the Windows 10 PRO and latest updates, Version:- 20H2 - OS Build:-19042.867

1 Like

Our software has a Windows service. Unfortunately most uninstaller programs don’t know how to deal with Windows services properly, so it causes the app to completely fail.

Please do this:

Go to add/remove programs and uninstall GlassWire (don’t use Revo please).
Now install GlassWire again “clean”.
Reboot again - fixing some things that could have happened with a third party uninstaller.
Now go to add/remove programs and uninstall GlassWire again.

Now if you install GlassWire again one file time using the “clean install” option, the issue should be fixed.

Since two of your apps failed during a power issue I’d guess that maybe your hard drive was somehow corrupted. You may want to try these ideas suggested by

Also I know it sounds silly to uninstall/reinstall so many times but we’ve found this solves the issue in most cases when a third party uninstaller app fails to remove our Windows Service properly.

Windows has scanned the file system and found no problems.
No further action is required.

482832695 KB total disk space.
199509224 KB in 599586 files.
351736 KB in 133252 indexes.
2549735 KB in use by the system.
65536 KB occupied by the log file.
280422000 KB available on disk.

  4096 bytes in each allocation unit.

120708173 total allocation units on disk.
70105500 allocation units available on disk.
Total duration: 58.42 seconds (58425 ms).

Stage 1: Examining basic file system structure …

Stage 2: Examining file name linkage …

Stage 3: Examining security descriptors …

I have uninstalled it 3 times using your uninstaller plus installed it 3 times and rebooted each time.

It now starts and tries:- “connecting to local server” which does not seem to work.

Also, I can active and enter the code but that also tries to connect with something but that does not work.

Did you check “clean install” with our installer? It is an optional part of the install process. It’s required to fix the issue if your database was corrupted due to the power loss.

Sorry for the headache and thanks for your patience.

Why can’t GlassWire connect to its local server and why won’t GlassWire’s graph load?
If GlassWire’s graph will still not load please check to see if the following Windows services are running in the Windows task manager:

  • WlanSvc (WLan AutoConfig)
  • BFE (Base Filtering Engine)
  • EventLog (Windows Event Log)
    This one WlanSvc (WLan AutoConfig) was stopped and only after researching this I found out how to change it from Manual to Automatic.
    After this, it still would not start so I reinstalled all the programs that autostarted when starting Windows 10. After uninstalling Glasswire, rebooting, and reinstalling Glaswire I saw a message that Glasswire would automatically start when the computer restarted. Another reboot and Glasswire connected at once I could activate it. Now I have a fully working computer and Glasswire.
    Thanks for your assistance.


I’m glad it’s working! Our latest software should link to the article that has this info. I should have remembered to put the same info here in the forum. Sorry about that!