No things on "Things" tab

Today my Win 7 machine got this notification: “Device list changed, device ‘Unknown’ added”.
I went to the Things tab and it shows no devices at all where I normally see my PCs, Tivo, thermostat, etc.
The ‘Things monitor’ in security settings has always been enabled.
I’ve tried Scan with DNS and IP set and rebooted my PC, still no things.
The Scan normally takes 10 seconds at least, now it finishes instantly, so it’s not scanning much.
My other PC (Win10) still shows things.
Both are running GW 2.2.241 and Bitdefender and connect via ethernet.
This problem may been occurring for a long time, maybe since the last update, I don’t know.
Any ideas?


Is that PC connected via Ethernet or WiFi?

Ethernet, as mentioned in my original post (not being snarky, just had to pad my reply to 20 characters, :grin:).

Oops, sorry! It’s a known bug. I can send you a test version that fixes this privately in the forum, or you can wait until the update is out this week or next. Please let me know what you prefer.

I am in no hurry at all so I’ll wait for the update.
Thanks very much Ken.
I hope you’re all doing well there.

1 Like

Hi! I have the same problem. “Things” tab is empty. My PC is currently connected via WiFi. But this situation with empty list of Things occurred a problem from time to time, on cable connection too.

Here my screenshot

I’m using PRO version of GlassWire.


If you go to our top left menu and choose “About”, what version of GlassWire do you have?

Hi, my version of GW Pro is 2.3.367.

Strange. If you install our latest version with “clean install” checked, does it solve it? Please note it will delete your history/settings.

I have latest version of GW right now. This strange “empty Things” state has occoured from time to time. Restart of GW was not resolve this issue. Only restart of PC. After reboot some times this issue has occourder on fresh run of GW. Change of network adapter (ie. disable/enable/switch WiFi) not help.

Ah, my system details:
OS Name - Microsoft Windows 10 Pro
Version - 10.0.19044 Build 19044
System Type - x64-based PC
Processor - Intel(R) Core™ i5-8250U CPU @ 1.60GHz, 1801 Mhz, 4 Core(s), 8 Logical Processor(s)

Any hints for me?

We believe we may have found a fix for this when it happens for some software/hardware combinations… we are working on an update.

Did you try the “clean install” instructions above? If that solves it, then the fix probably doesn’t apply to your situation.

Hi Ken,
I was reinstall of GW + clean up of all data. For now problem with empty Things Tab disappeared.