NonPaged Memory leak on VPN


#1

Glasswire seams to have massive memory leak problem when used in conjunction with a VPN. The issue persists even after closing the program, and can only be resolved by restarting the computer or uninstalling the program.

The issue has been happening for quite a while, and I noticed it was Glasswire which was using in excess of 10gb of nonpaged memory and it’s linked to how much is being downloaded. To test this, I tried downloading a game (26 GB). While downloading the game on VPN, the nonpaged pool kept gradually increasing until nearly all my ram was being utilized. (See pictures, the historical graph shows roughly the past 5 minutes, the second image is of poolmon.exe showing GWCD using 7 GB of non-paged memory. This number will continue to rise until my computer crashes). I paused the download, restarted my computer and resumed the download without the VPN running and there was no leak.

RAM%20rise

And without the VPN on, constant memory usage, no memory leak. GWCD isn’t anywhere near the top of poolmon.:

no%20VPN

This is a huge issue and should be resolved. I paid for both Glasswire Elite and my VPN service, I shouldn’t have to decide between privacy and security.


#2

GlassWire works great with a VPN.

Are you using Bittorrent? If so GlassWire must work hard to keep up with the thousands of simultaneous hosts you’re connecting to. To solve the problem go to the top left GlassWire menu and switch over to “Incognito” mode, or continue to use GlassWire as usual and keep in mind GlassWire will have to use a lot of resources to log all those hosts with Bittorrent.

Please email us details about what VPN software you using and what websites and other software you’re using simultaneously so we can investigate.
https://www.glasswire.com/contact/

Also, some free VPN services act as a server for VPN access for other VPN users, and this can also cause a connection to an unusual amount of simultaneous hosts.


#3

No I’m not using a Bittorrent. The images I showed are with downloading a game off UPlay.

The same thing happens with Firefox, granted its a lot more gradual, if I continuisly watch 4K Youtube videos it rises up again.

For me Glasswire is always on Incognito mode, and the example I had above was with Incognito mode on.

As for the VPN service, I’m currently using IVPN, a paid service. Not free.


#4

So are you saying a VPN makes no difference, and you must just use Firefox to reproduce this? What Windows version are you using? I use Firefox daily and I have never seen this problem, but perhaps it’s because I use Windows 10 and you use another version of Windows?

Please give as many details as possible and our quality assurance will try to reproduce this. Thanks for your report.

We’ll have a GlassWire update out on Monday.


#5

No, that’s the opposite of what I’m saying. Regardless of the program (Firefox, Uplay, etc), as data is being downloaded while my VPN is on, Glasswire’s nonpaged memory increases.

I’ve been using Firefox to watch a podcasts for the last few hours, and here’s the glasswire memory leak again, and it’s slowly rising. The only factors affecting this memory leak is the VPN being on/off and the internet usage. The more data that is being downloaded, the faster the leak, and the leak is only present if my VPN service is on.

I’m currently using Windows 10 Pro (Version 1709, build 16299.492).


#6

We had a customer with a similar problem in the past and we spent a lot of time investigating. It ended up his PC was infected with malware, so you may want to try some antivirus scans also.

Also, if your history is not important please try clearing in in GlassWire’s settings and see if it makes any difference.

GlassWIre will use system resources to keep up with a large amount of hosts that are connected, but for normal Internet usage GlassWire’s resource usage is minimal. If you want to connect to a lot of hosts simultaneously with applications such as Bittorrent or due to a malware infection, the best solution is to go to our top left GlassWire menu and choose “Incognito” mode.

Thanks again for your report.


#7

I have Malwarebytes Premium, I do a full scan weekly, and a nightly scan. I don’t have a virus or malware.

Also as stated,my Glasswire is always on incognito, so I don’t have history to clear, regardless I pressed clear all history and no change.

As we’re speaking, my GWCD is using 4 gb of nonpaged and it is slowly rising. This is purely a Glasswire/VPN issue. If I turn off my VPN and continue using my computer as I normally would, the nonpage memory stops increasing.

There really should be a maximum nonpaged limit set for your drivers.


#8

GlassWire uses a caching system that keeps its resources minimal. I will switch to Incognito mode now and see if that can help me recreate this.

We’ll continue to try to recreate this on our end. Thanks for your report.


#9

@LarceNewYork

iVPN was nice enough to give us a free trial to test with to see if we could recreate this issue.

We could not recreate the issue. We used the default settings with iVPN. GlassWire used a max of 2MB of memory.

We tested the issue all day long today. We were running multiple 4k videos on Youtube and downloading big files.

If you are still experiencing this issue please email us a link to this thread https://www.glasswire.com/contact/ and we can send you a custom version of GlassWire to test with some minor changes that may help.


#10

If it helps, I was connected to US servers while the leak was happening (The leak seemed to have been less when connected to Canadian servers for examples). But I have since reformatted my computer and I will be keeping an eye out on the memory usage.

Another issue I’m seeing is while connected to the same VPN, some programs bypass the firewall. I’ve had this issue before and it hasn’t been resolved.

The two shown are Nvidia services, and while uploading this image I viewed it using Nomacs image viewer (which is also blocked by the firewall) and that bypassed the firewall as well.

As far as my experiences with Glasswire go, it has been awful when using it in conjunction with VPN services.


#11

If you go to the “About” window in GlassWire, what version are you using? We recently made some changes that might solve your issues.

If you click the NVIDIA icon do the apps have different file locations? If so they are different applications and GlassWire’s behavior is correct. However, I have an NVIDIA card myself and I have not seen this behavior.

We’d need details on how to recreate the problem on something “bypassing” the firewall. We use the Windows Firewall API and it’s very reliable and used by IT and Infosec professionals world-wide.


#12

Version 2.0.123

The Nvidia apps don’t have different file locations, some of the repeating ones are from older installations which I had yet to remove, but the ones connecting to the internet are obviously the ones that are installed currently.

I have uninstalled/reset firewall/reinstalled glasswire and I’ll keep an eye out to see if they will bypass again.


#13

After the reinstall, and a reformat, I’ve noticed Cortana bypassing the firewall. Infact I have a few apps installed from the windows store and those are bypassing it as well (Like the weather network app).

I know some Windows application bypass the host file, but do they also bypass the firewall?


#14

@LarceNewYork

What does it mean “bypass the firewall”? We use the Windows Firewall API and it is never bypassed, unless it’s turned off completely in Windows.

I use Windows 10 and I have not seen this problem with Cortana, but I’ll keep looking and ask our QA to double check. Thanks for your feedback.


#15

The two ideas are different enough that they are not really comparable under normal operation.

The hosts file is used as part of the name resolution service (DNS, etc.) which finds the IP addresses for names such as this computer or this website. “Bypasses” could appear for several reasons: IP addresses can be hard-coded into programs so the Windows name resolution service doesn’t have to be used; and, even if name resolution is used, the order in which the host file is referred to can be changed.

The Windows Firewall cannot be avoided so easily. It inspects all network packets (ip v4 & v6) and there is no legitimate scenario for avoiding this inspection. However, if there is improper configuration and the firewall rules are not correct then this will have the appearance of programs “bypassing” the firewall.


#16

Yes I understand that, but there must be a reason why the firewall is being bypassed. For example, I can confirm that all incoming and outgoing connections are blocked unless specified (As shown in the windows firewall dialogue).

So it should hold that no programs have any internet connection when first launched/installed. But I have witnessed several times where programs are accessing the internet. Some have access for a brief period… ex: I launched KeePass after reformatting with Glasswire set to “Ask to Connect”, and KeePass was able to check for an update, and notify me that there was one… which I found odd and as I clicked update it said there was no internet connection. Meaning there was an brief moment where it was able to connect to the server to check for the update.

And there have been other programs which ignored it all together. For example the Weather Network app I installed from the windows store just ignored it and had no problems connecting and maintaining a connection to update its information and this activity was shown in GlassWire. Now if I “unblock” the program and re-block it the firewall works as it should but that isn’t really acceptable in most cases.


#17

I installed an app called “The Weather Network” from the Microsoft Store for the first time and I got an Ask to connect prompt, then I denied it. Is that the app you are talking about? I am sure I have never installed it before because I don’t install apps from the Microsoft Store on this machine.

weather_network

I will ask our QA team to also test and see if they can recreate the problem you are experiencing. Thanks for your report.

Please confirm what version of Windows you are using? I am on Windows 10.


#18

Yes that was the app, but I’ve noticed the same issue with other programs (For example the previously mentioned Nvidia Backend) I’ve had this same issue before and I was given a “custom” version of Glasswire to install and it didn’t seem to help but then again this issue is largely when an app is recently installed and launched for the first time. Eventually I run out of “new” programs that I need to install and run.

My current windows version is: 1803 (OS Build 17134.165) (At the time of the issue I believe my windows version on a previous build, not sure which).