Not compatible with this device


#1

Hi,
I am trying to install glasswire on my android tablet and it say that this version is not compatible with this device. How do I solve this issue? I have it installed on all other devices in my house with no issue.

Thanks
Megan


#2

@Megancarroll.2807

Does this tablet have an old Android OS version?


#3

It is a galaxy tab 4 with lollipop 4.4.2 I think


#4

We don’t support that OS version anymore due to Google Play requirements. They don’t want such old apps anymore with older libraries according to Google, sorry.