NOT RESOLVED - Glasswire works after initial install then fails after reboot


#1

I Have Glasswire (Paid for version) on three devices

  1. Main Workstation
  2. FTP Server
  3. Laptop

The Server and laptop are running fine but my Main workstation has developed a weird trend.

Every Morning I switch my Windows 10 Workstation on, Glasswire is greyed out and the message “The Glasswire service stopped running” Restart GlassWire. But the service is running in the services.msc. I am worried someone is trying to hack in to me and disabling my Glasswire to do it without trace.

I uninstall including all settings and re-install clean and it works fine till the next reboot or shutdown, then it comes up Greyed out. RInse and repeat.

Glasswire%20Error

I was told to check the Glasswire logs, but the instructions weren’t clear. My Log shows nothing except

log_path=c:\programdata\glasswire\service\log
log_level_file=-1

This was entered by me as the instructions weren’t clear as I mentioned. I am in the process of changing all my Passwords and have disabled Firefox Master password which was useful for non secure logins. I keep my secure passwords in Keepass.

This is frustrating, I need help Urgently please


#2

@Dan_Brown

Sorry for the issue. FYI we plan to have a major update out Monday that may solve this.

Meanwhile, do you have any .dmp files on your desktop after this happens? If so it’s a driver crash and you can email us the .dmp file logs (using a cloud service like Dropbox because the file is quite large). https://www.glasswire.com/contact/ Please include a link to this thread in your email.

One thing we have noticed lately is that the most common reason for this issue is a database corruption of GlassWire’s logs. If your graph history is not important you may want to uninstall GlassWire, reboot (important!) then reinstall using our “clean install” option. it may solve the issue for you quickly but you’ll lose your graph history.

If you’re worried about Malware try updating Avast also and do a full scan.


#3

Hi Ken

I have done all the above and more. The Driver doesn’t crash or leave any .dmp files or events in the event viewer. It just simply works the first time you install it and never again. I have protection coming out the Wazoo.
I am just paranoid. I Have done clean installs with no settings carried forward, deleted previous directories.

My FTP Server has login attempts every night but it’s locked down tight. I like Glasswire because I can see at a glance if there’s a serious hack attack and the flag the Country of the attacked (or his VPN) comes from.

It has worked fine until the last few weeks. Probably a Microsoft update is killing it or something. I hate Microsoft but that’s how I earn my living.

I have Malwarebytes endpoint, AntiRansomeware, anti-exploit, Windows Defender (FWIW) plus Avast Business. I also have Hardware firewalls. I really want my Glasswire to work.

Dan


#4

No Microsoft update will cause GlassWire not to work, otherwise we’d be in crisis mode trying to fix it.

I can only guess it’s one of those other security applications. Please see if they have any mention of killing our driver and if so white list GlassWire, then it can run.

Meanwhile we plan to have an update out Monday. If the update does not solve the issue please post again and we’ll find another way to see details of what is happening with your PC.

On Monday please follow the instructions above with the clean install. You’ll see a post in the forum once the update is live.


#5

Rebooted this morning, Problem has resolved itself. So Avast Business/Malwarebytes/Microsoft 1803 Build 17134.407 has decided it doesn’t mind Glasswire anymore on my Main workstation.

I was just about to start complaining again :slight_smile:


#6

Dang - Back to not functioning again :frowning: I can’t figure this out. Worked for one day and then back to crippled mode. Any suggestions anyone?


#7

Malwarebytes works great with GlassWire, but I see you have two other security applications with it (also made by Malwarebytes?).

Do these second and third applications have options to white list things? Perhaps you can white list our service and see if that solves it?

If you clear your history in settings does it help? Does your PC have much memory, and do you use Bittorrent or something similar?


#8

Hi Ken

Avast Business and Malwarebytes products were sold to me by the same supplier as I am a reseller for them, Malwarebytes main Program , Malwarebytes Anti Exploit for business, Malwarebytes anti Ransomware They confirm 100% compatibilty with Avast Business. I have whitelisted wherever I can think of. I know Avast have been having a few problems so they are the likely culprit, I was having a Premature Appreciation yesterday when everything worked but today just as the Pictures at the beginning of the thread.

I do have µTorrent loaded but haven’t used it for a month or more. Someone has decided to extract revenge on me and is trying to get in every which way they can also by attacking my biggest customer as well. So I am paranoid on two fronts.

With regards Machine specs

Windows 10 Pro 1803 Build 17134.407
Intel i7 - 32Gb RAM - 250Gb Boot SSD - 8 Tb Seagate Iron Wolf Data drive, plenty of space, Plenty of cooling, Carillon custom Rack Mount Chassis.

The funny thing is there are no log’s or Dumps to analyse

I really like this software and want it to work on all my PC’s, Windows 10 Pro Laptop is fine and HP Server Proliant Microserver running 2008R2 is fine.


#9

@Dan_Brown

If there is no .dmp file on your desktop then GlassWire is most likely not crashing. Is it possible one of these applications could be killing our process? Perhaps there is a white list option for Avast for our service?

Our service is called “GlassWire Control Service” in its description.