PLEASE add option to disable notification fade-out

I admit, the fade-out is sexy for the notification popups, but they also OFTEN cause me to literally shout out a long string of curse words (in fact, I just did while attempting to create this post), because the entire time it’s showing, including during the full length of the fade-out, it’s stealing focus.

During that time, I can’t click on anything else including what I was previously typing into because it just sets focus right back to the notification, and what I’m assuming is also some large invisible window that it’s a part of, because sometimes when the small notification is showing and I click way away from it, the main GW window will suddenly show.

What’s worse is, if you happened to have the full GW window showing, click some other window like your browser, then a notification shows, and you click back into your browser, the next second the GW notification AND the full GW window show in full focus. If you were typing away while looking at your fingers and look up during that, all hell broke loose; only a small portion of that long sentence you just typed was entered, and God knows what else just happened, windows are flashing all over the place, settings in apps may have changed accidentally, and so on.

Please, just add an option to disable the fade-out. Normally I disable all fade-ins and outs in all my apps including Windows itself anyway.


1 Like


Sorry for the issue. I have never heard of GlassWire notifications stealing focus. That would drive me insane also so I understand your frustration. I run GlassWire 24/7 in its default mode while I help customers like you, so I would be unable to work if our notifications stole focus.

If you go to the top left GlassWire menu and choose “About”, what version do you have?

Do you use any screen reading software or software that helps with controlling windows of applications?


I don’t have any screen readers or anything else that should be setting GW as the top window all the time that I can think on.

Nonetheless, adding in an option for us to completely disable the animation would be, and seems like a natural option to add. It seems very strange not to have that option; even Windows gives users that choice.


1 Like


Thanks. Please note though that GlassWire should never steal focus with any notification and nobody has ever reported that.

I will see if we can figure out how this is possible.

What Windows version do you use?

You can disable desktop notifications completely also if you go to settings/security.



I might have discovered another program that was causing that issue. It’s called Buzof - basta . com/buzof. I had a profile for it to auto close some of GW’s nag screens, like the constant update notification, etc.

At first I had chosen “disable” on It’s menu to disable the entire app from doing anything, but GW was still acting up, so I assumed it wasn’t the problem at first. Then I completely exited it, and GW doesn’t seem to be acting up any more. However, When I closed Buzof I also closed a handful of other apps, so I’m not positive that was it.

I would still like a setting to disable the notification aminations though because in the past I have still run into similar issues with it blocking me from doing things until it fades out.

thanks for listening!