Problem with Glasswire and Nvidia Optimus

Since, I think, the latest GPU drivers update my Nvidia 540m keeps activating because of Glasswire; I even tried to force it to not use the discrete GPU but it ignores my settings. Is this a known bug or there’s something I can do about it?

I don’t want to uninstall Glasswire but at the same time I can’t have my discrete GPU active all the time, it drains the battery much faster.

We have never heard of this problem before. Are you sure there isn’t a setting with Nvidia that can solve this?

There is a setting in the Nvidia panel, problem is it’s already set to use the integrated GPU instead of the discrete one. I noticed this problem today after updating to the latest drivers, somehow it must have screwed the settings.

then try to reinstall it
i really don’t think that it causes by glasswire
i too have Nvidia PC and Laptop but they works fine.
i am really sure it’s something else .
and if that solution can’t help you then go to event viewer and give us the log

I already tried a clean reinstall of both Glasswire and the Nvidia drivers with no luck. Which log do you need?

We’ll try to reproduce this and fix it. Thanks for your report.

see if there is an event in event viewer that is related to glasswire or nvidia
if there is any evnet name like nvidia and glasswire then we can solve your problem

Nothing out of the ordinary, just the usual stuff. What bugs me is that the Nvidia Panel reports that glasswire.exe is using the discrete card even if it also says it should use the integrated one and I can’t force to use it.

Then i can’t help you
it seems like there’s no way around
but why don’t you try to run the software in SAFE MODE.
if it will run fine there then
i am really sure about that some other software is interfering with it.

I already tried that but unfortunately the Nvidia Optimus system doesn’t work in safe mode, it just use the discrete graphics for everything because of the lack of the Nvidia control panel.

what kind of laptop do u have ?
plz give me the specs ?

It’s an ASUS N53SV with a 540m and an i5 running the latest Windows update.

EDIT: ok, I tried finding an older version and it keeps having the same problem so, at this point, I think it’s a drivers problem.

  1. it could be that you became infected with a Bitcoin mining program.
  2. the drivers you have updated .
    Solution for 2.go back to the previous one and see if that fixes your problem .
    if not then Download SPECCY.




–Run Speccy, Top left corner FILE > PUBLISH SNAPSHOT
and upload it here

As I thought it was a drivers problem, today I had the time to do a rollback and it resolved the problem beautifully. I think I’m gonna stay on this version, afterall my GPU is so old they probably stopped updating its drivers years ago and they include it in the update list only because they have to.

Thanks to everyone that has helped me and take note that the latest Nvidia drivers may interfere with your program on some machines.

I told you that was your driver problem
well if end wells all wells
and plz replace your graphic card or should i say replace the laptop

I’m saving up but unfortunately this laptop’s not gonna go away anytime soon. Thanks again for the help

I confirm the issue. Asus Q550lf laptop with NVidia Geforce 745m, 350.12 latest driver. Discrete graphics is constantly on, and Glasswire is using it according to the built-in Nvidia indicator. Forced Intel integrated graphics via Nvidia Control Panel is being ignored by Glasswire. Other apps react to this setting without issues.

Yeah, that’s an unfortunate bug in the drivers. As I said above rolling back a couple of versions solved my problem but I don’t really know if it’s viable for you: my card is much older than yours and because of that I rarely play modern games so stopping the updates for a while isn’t a problem.

Let’s hope this gets fixed in the next Nvidia release.