Resolved: Unable to establish connection - Remote Monitoring

Yes, both computers were on ethernet with wifi disabled.

I will try connecting them and only them with a completely different modem (this will be the third). I want to eliminate the modem from any consideration. They will also be disconnected from the internet.

Now I have connected my computers with 3 different routers – the last is a Westell setup exclusively as an ethernet network. I’m still not able to establish a remote connection.

I’ve also added a new computer to the network. This one is running Windows 7. Still no remote connection.

And after adding this last computer, there is a new problem. With Basic, you say that I can have 3 remote connections, but only 2 remote connections show on my Local machine. To get the new computer to show up, I had to disable the remote connection for the previous two computers. (By “remote connection”, I’m referring to the display of Glasswire output in the left hand margin of the Glasswire window.) Because I can’t actually establish the connection, the two remote mini-displays are blank – but I should be able to display three remote connections plus my Local connection. The three remote devices do show up in my Network tab.

BTW, since the Network tab is a display of my network, I should also be able to see my local machine in that display, but it doesn’t show up at all.

All it looks very strange to me…

Did you try establish connection between your computers with Remote Desktop? If yes, was it successful or not?

Hi Rich,

It seems like something blocks the connection on your remote computer. You said that there are no any third-party firewalls. But could you check Windows Firewall status on the remote PC? Is it on? Did you try to disable it just in case?

You can find the Firewall settings here Control Panel\System and Security\Windows Firewall. Click at the “Turn Windows Firewall on or off” at the left hand panel and switch off the firewall for each profile (Private network settings, Public network settings etc.).

THANK YOU, Richie! While I do know quite a bit about firewalls and how they work, I’m not real strong about the implementation of Windows Firewall. You taught me to look for something I wasn’t aware of and now I have a remote connection established on 2 of my 3 remote machines. (More on the 3rd below.)

Basically, I was setting the firewall to off on the Private network I know I’m using, but nothing else. When I followed your advice and set it off on Private, Public and Domain (somehow I had missed the import of that Advanced Settings under Firewall). Once I got everything off, the connections started.

I’m going to consider this thread resolved. I still have that 3rd machine to connect, but there must be some difference and I’ll search that out. I’ll open new threads if needed for that machine and for some of the other questions I’ve come up with and reported here as well as some new issues (all cosmetic or relatively minor).

Tom, no I didn’t try to set up the Remote Desktop other than to activate it. That did nothing for this issue, and I wanted to focus on this.

BTW, while working this, I’ve used Netgear Genie for assistance – and found and reported a number of minor bug there too. Having a remote connections on one of my machines, I just found a new Genie bug this morning.

Thanks, for the help. Rich

PS: I realized that if anyone else has a similar problem, they might want more info on the solution.

For each remote machine, go to
Control Panel > System and Security > Firewall > Advanced Settings
I started by setting all the tabs to “off” to make the remote connection, but then went back and started turning them on. Both the Domain and Public tabs can remain with full Firewall protection. In the Private tab, I selected “Customize” and unchecked the boxes for Wifi (leaves the Wifi connection not protected by Firewall rules). That is where I am now that allows full remote connection ability.

But that does not enable remote connection on my 3rd machine.

Rich

It’s strange even more, since usually one don’t need disable firewall to have GlassWire working.

1 Like

Glad to know that this solution worked out!
I guess there are some custom rules on the Firewall, which blocked the connection. So if there are no any important settings, you can restore the default settings in a following way:

  1. Run GlassWire and unblock all the applications under the Firewall tab if you’ve got anything blocked;
  2. Open Windows Firewall settings Control Panel\System and Security\Windows Firewall;
  3. Click at the “Advanced settings” at the left hand panel;
  4. Select “Action\Restore default policy” at the main menu of the Advanced settings window.

But please keep in mind that this will also remove the exceptions added by Dropbox, uTorrent etc. It’s not a big problem actually, since you’ll be notified when the application will try to establish connection, so you’ll be to add the exceptions later.

Good suggestion, Richie. I hope you don’t mind, but I want to transfer this discussion over to the new thread I opened about this unique remote server.

Today we added a Blog post about our remote connection abilities.
https://blog.glasswire.com/2015/11/11/monitor-remote-servers-with-glasswire/

1 Like

Thanks for the tip, Ken.

Am I to understand, you need two versions of GlassWire? Ahh. I just purchased Basic. What do I do? Install it on the laptop? Oh, I’m trying to get my laptop working from my desktop in which I have GlassWire Basic. I think I followed everything except installing it in the laptop.
Thanks

@OleSmokey You can monitor multiple PCs with the Basic version. Please check out these instructions https://www.glasswire.com/userguide/#Remote_Monitoring. Thanks!

Servo,
I tried that but I did nothing to the laptop. Reading one of your posts led me to believe I needed GlassWire on both machines. It mentions nothing there that states that. I tried to install GlassWire on the laptop and it took it. But I can’t register it. Basic only covers one machine. I don’t particularly want to pony up another $50 for that at this time.

No additional Basic codes are required to monitor a PC with your Basic license. Sorry for any confusion.