Resolved: Unable to establish connection - Remote Monitoring

I noticed a number of problem reports last year on this topic and would have assumed that they would be resolved by now. I’ve tried all the suggestions made, but still get the same error.

My computers are on the same subnet, so I don’t know why port forwarding would be required, but I tried it anyway. No luck. Also noticed that there is no detailed instruction on port forwarding as promised other than a pointer to Wikipedia. I have Basic 1.1.32 with a simple network (all devices connected to a router with an internet gateway connection). Most of my devices show up in the Network view, including the remote computer I want to access. Glasswire is running fine on each computer as far as I can tell. The overall Usage stats match what I get with my router software.

I wish we could show detailed port forwarding instructions, but since every router and network is different it’s difficult to do so.

When you go to Server/Remote Access on your remote machines I assume you unlocked and allowed access there with a password? I’ll ask our dev team if they have some other ideas why this isn’t working for you.

Meanwhile we’re working on a new system for making remote connections that will be much easier.

Something better would be great – here’s hoping. And, yes, I followed those instructions to allow with a pw. Nothing. Re-did it multiple time at each end – no good.

As far a port forward instructions, I did see your complexity post, but also since saw the post about preparing those instructions. I think it would be good to provide a set of reasons why you might need forwarding and why not. For example, as far as I know, it has no place with a single subnet like mine but might if there was a larger network.

If you can ping host which you want monitor - then you don’t need port forwarding.

Thanks, Tom. Sure – 3ms response time.

Ok, I’ve waited overnight, did a complete uninstall (including Program Data), re-install, re-activation and again re-did the allow monitoring on the remote machine. I even set the remote machine to allow Remote Desktop monitoring (though your comments say that Glasswire Monitoring uses your own facility). Regardless, I am still unable to connect to the remote machine.

This afternoon, I will have full time access to that machine, so any other ideas would be appreciated.


Do you have any third party firewall software on that PC that could be blocking incoming connections? Under GlassWire’s firewall tab is it blocking itself from accessing the network? Sorry for the problem. I’m waiting to hear back from the dev team.

I’ll check this as soon as I can, Ken – my wife forgot she had a commitment and ran off with the pc to do a presentation {sigh}. I know there is no 3rd party firewall, but need to check about the block. I don’t think so, but…

Just to be sure. I have the paid Glasswire (since yesterday :laughing: ), but the remote pc has the free version. Since I should be able to monitor 3 “connections”, I’m assuming that means this other pc. (It occurred to me that “connections” could refer to a subnet and that would be why I can only see my one subnet in the Network list (mentioned in other posts).

if you have telnet installed, could you please run in command line

telnet place_remote_host_ip_here 7007 ?

and post result here?

1 Like

Hello Rich,

Please try these instructions exactly.

Your Remote PC:

  1. First go to the top left GlassWire menu and open settings\server\remote access;
  2. Check the box “Allow remote access by password”;
  3. Click “Change password” and set the new password. Try making the password simple for the first connection only, to be sure you don’t have a typo.
  4. Click OK;
  5. Open settings\server\general and make sure that the “Remote access state” is “Allowed”

Local PC (the PC from which we are going to connect to the remote PC from):

  1. Open Settings\Client\Remote server;
  2. Click “Add new server” and select it on the “Server list”;
  3. Type the name of the server;
  4. Type the IP address of the remote server; Go to from the remote server if you’re not sure.
  5. Type the remote server password, which was set previously;
  6. Check “Enable connection”;
  7. Click OK.The connection process should start. If the connection was successful please use a secure password, or limit connections from a certain IP address.

Did the connection fail? What is the error message you see when the connection fails? Are the local and remote versions of GlassWire both our latest software versions?


Edit: After a lot of searching for a spurious error, a reboot resolved the issue and telnet is enabled. Result of the telnet:

If you have any suggestions, I’m very open. Otherwise, thanks, you’ve given me a new tool to research and work with.


Update: On the remote pc, “netstat -a” shows that 7007 is LISTENING. Checking through Windows Firewall although Glasswire shows that Glasswire itself is not blocked.

[Deleted original error info.]

Ken, Followed your instruction and connection failed. See the clip below.

When I ping, I get an immediate response. A tracert returns with the proper computername/ipaddr with only the 1 hop. All is as it should be with two computers on the same subnet.

Using fails because it is outside of my routers and has no access to this subnet. It returns the name and address of the Verizon wireless antenna that provides our internet access (gateway),

Both machines are on Glasswire 1.1.32b which I downloaded (re-downloaded) in the past two days.

I have no issues with internet access or my firewall nor with any external traffic getting through to my systems in my subnet including Glasswire. You asked yesterday if the remote computer firewall has Glasswire blocked – it does not and only Windows Firewall is running.

RSATom asked me to try telnet, but it is not installed on my PC and Win10 says another device is blocking my attempt to install it. Researching that.

My Genie Network Map may help you understand how I’m setup. This subnet is connected to the shown internet gateway which has the wireless antenna in its local network. My subnet does not interact with the gateway subnet except to define the gateway as its DNS server.


Update: On the remote PC, port 7007 status is LISTENING. I found that while Glassware Firewall shows that both Glassware.exe and Glassware Control Service are allowed, in Windows Firewall, only Glassware.exe was explicitly allowed. I added Glassware Ctl Svc and then I rebooted both machines. I am still unable to establish a remote session to the other PC.

Inline image 1

Inline image 1

Could you please run
telnet ip_address 7007
from console on host you’ve tried to connect to?

But, please place IP there, not network host name.

ok – using the console of remote computer with ip addr and entering “telnet 7007”, the command screen is cleared with a thick blinking curser (dash) in the upper left. Entering any series of keystrokes (including telnet commands) moves the cursor over and after 3-5 keystrokes returns the display to the Window Cmd prompt.

My monitoring (main) computer is Even if I set that computer to be a remote client with port 7007, while I get the same netstat -a response that 7007 is LISTENING, I get the same failed to connect if I try to telnet that port from

On both computers, from a CLI I can issue telnet with no parameter and they both enter the telnet client with a prompt of “Microsoft Telnet>”. Both take telnet commands.

Update: I think I’ve verified that this remote session SHOULD work, but it still does not. I removed and reinstalled Glasswire on the remote machine. I have verified that “telnet localhost 7007” works on both machines establishing an internal telnet session. From my machine, I can establish a telnet session our to the internet and retrieve info (to I have set my machine up as a remote server and have established a Glasswire remote session with myself. (My Glasswire session now shows 3 session – Local, SheilasYoga2 (blank) and Rich-Win10 (duplicate to Local). Though I’ve been using Windows Command sessions longer than most of you have been alive, to eliminate any possible fumbling on my part, I install PuTTy which still failed to establish a telnet with the remote server. I’ve also examined the Firewall on both machines and disabled the Firewall for each before trying to telnet and set Glasswire. Also the remote SheilasYoga2 cannot open a telnet to my machine. I’ve also completely reconfigured my own network to try my router as an access point (subnet changed to 192.168.1.x) to no avail and have returned it now to router and all machines back on subnet 10.0.0.x. Still no success.

I’ll keep working, but I hope ya’ll have some ideas. I’m working mostly now on the hypotesis that there is something set on that remote machine that is refusing telnet and Glasswire access, but I have no idea where else to look.

It means connection was successful.

So, I think you have all working right on And I think your problem is somewhere between and If I understand correctly, all your computers connected via wi-fi. It’s possible your router have some protection enabled to limit connections between wi-fi clients? Could you try connect your computers to router with ethernet cables to check if it will work? But please disable wi-fi when you will test it to be sure connection is over wire.

Good idea, Tom. Thanks! I’ve search the router for just that and it’s pretty straight forward, but I will try the ethernet connection (removing the wifi).

Hope you read the Update I put on that previous post just as your were sending this suggestion.

I’ve learned that Telnet Server is not implemented (“deprecated” is the word) in Windows 10. Therefore, although the Telnet Client can be enabled, you cannot telnet to a remote machine that runs Win10. How that relates to being able to telnet to localhost, I don’t know.

I did set up a “remote” session with itself on the machine that I am unable to connect with. So a remote connection is apparently possible on that machine. I also have installed Glasswire on another machine in my network. Again, I can’t establish a remote connection to that machine either. Yes, that suggests something in my setup or on both computers, but has not provided an answer.

I’ve again scoured all these machines for any Firewall or other software block as well as searched my router. I’ve sent a request for info to the router forum also, but the initial response indicates the router is probably not at fault.


Using telnet is just convenient way to check if remote host is accessible and specific port is open on it. Nothing more.

Did you try use ethernet cable?

Ok, first off, no, changing to ethernet (wireless disconnected) does not allow me to establish a remote connection. (Sorry, this took a while – as you know, Tom, any change has more impacts than you really anticipate. I have three PCs included on this network – mine, Sheila’s and my Win10 beta. It turns out Sheila’s Yoga does not come with ethernet (Lenovo changed that a few years back). So I had to activate my Win10 beta which is not only back level due to all the network upgrades I’m making, but the level it has blue screens frequently. I did squeeze in the remote connection test though. Now that machine is updating to the current level.)

I understand now that telnet was just a test tool – but it doesn’t work on Win10. The port appears to be open ( 7007).

But now I’m dead in the water without some Glasswire update or some new option to check.

Update: My other “remote” server that will not connect is now fully up to the current level of Win10 beta. That did not help me connect :<). Maybe should be :<(. I did enable Remote Access although I didn’t expect it was needed and, sure enough, it didn’t help.

But at least so far I have not hit a blue screen with this update to Win10.


Did you connect with ethernet both computers?