Samsung S10e VPN does not work making GlassWire Firewall VPN unusable (solved) 2020

Hi, I’ve recently downloaded Glassware for android, it works good but the main feature because I downloaded and subscribed it was the possibility to block network access to some apps. But unfortunately it doesn’t works.
I’ve a S10e with latest update available(August patch) in EU for Exynos. I’ve tried everything: unistalling antivirus, resetting network settings, disabling battery optimization for GlassWire and giving him permissions to run in background and use data in background. I tried activating VPN always on for GlassWire, but it says it is disconnected.
I’ve tried to use another app to check if it is an issue with the OS and the other app(NetGuard) didn’t work either.
When both apps ask to add the VPN, i click on OK, but then nothing happens, I don’t see the key icon on status bar.
On GlassWire if I select to disable network access to all apps and then readable it, I can’t turn off the firewall. The only way it is to force the app to stop and then I can disable it. Sorry for my english.

@ARGO

I wonder if something could have happened to one of our permissions. Could you uninstall our app completely, then restart your phone, then reinstall our app from Google Play. Now turn on the firewall and try to block something.

Please be sure the firewall is switched to “on”.

Are you using another VPN simultaneously? Android only allows one at a time and the VPN is the only method we have to block.

Perhaps this guide is also useful: https://www.glasswire.com/android-help/#glasswire-firewall

I tried it, it does not works. When I try to block an app(e.g YouTube) it does not block it, I can use the network with YouTube and the key icon on the status bar does not appears. After I try to block an app, I can not turn off the firewall, I have clicked on the other side of “on” but nothing happens and I have to force the arrest and then I can disable it. I have not other VPN apps or configurations.

Edit: I tried installing some VPN apps, but none works. I think something is broken in the OS or a setting that blocks VPNs. I can not say that I had not issues before this update(OS update) because I have never used a VPN before.

Edit2: I tried Avira VPN and the key icon does appears in the status bar and the VPN works. It seams it is not an OS issue.

Edit3: I do not if it helps, but I left NetGuard running (I does not works the network filter), but I got a notification of a java exeption: java.lang.SecurityException: Neither user 10623 nor current process has android.permission.INTERACTOR_ACROSS_USERS

Edit4: I connected my phone to my laptop and to android Studio to read logcat, but i could not find a common patter between GlassWire and NetGuard that is not present in Avira. The 3 apps throw the same vpn warnings, but at the end only Avira works.

@ARGO

Is it possible there is an OS update available for your phone? I do recall that in the past some Samsung phones have had known VPN bugs and I have read reports on this in the Samsung forums while trying to help customers.

In most cases Samsung would put out an OS update that would solve the issue.

It’s true that some phone manufacturers can introduce VPN bugs with some phones and if the VPN API is broken there isn’t anything we can do unfortunately because we need this API to turn on our VPN. All other VPN apps should also be broken if this is the case though and it sounds like that’s the case for you?

@Ken_GlassWire
I tried NetGuard and it does not works, but I tried Avira VPN and it does works. I have the latest update avaible(August patch)

@ARGO

I found this thread on Reddit. It appears it’s not just you with the issue.

They said this is a solution:

" I just got a response from support, directing me to disable all Dual Messenger apps if I have any active.
So I disabled my dual WhatsApp, used for the second sim and AdGuard managed to start the VPN, but only after leaving my phone locked for about 10 mins (as instructed by support). But something is definitely wrong, because I don’t see the notification with the key icon, from Android System, regarding the VPN connection. Well, I guess for the moment this is a welcomed fix."

To be honest though I don’t get how this could fix anything… it seems like a strange explanation and fix but if you understand it maybe you’ll know how to try this? It’s very weird.

@Ken_GlassWire now it works, when i disable the network to an app, the key icon appears and the app can not access to to network. I had 2 whatsapp because I have 2 numbers.
This is a weird bug. Maybe GlassWire can report it to Samsung, I think they would listen to a company rather than a single person. Thanks you so much for the help

1 Like

@ARGO

I’m glad it’s solved! Maybe someone else will find this and it will help them with this issue.

I will update the Title of this post so it’s more searchable for others.

1 Like