[Solved] Can't activate Firewall with either GW Basic or Elite


#1

So as of yesterday for no reason Glasswire disabled it’s own Firewall and won’t allow me to re-enable. I’ve got a license for both Basic and Elite, and I’ve tried with both of these enabled.

The diagnostic steps I’ve tried so far are:

Completely removing the application, purging all system files and registry keys. I’ve restored the MS firewall to defaults, and downloaded a current .exe from the website. After restarting my machine I will perform an install, reboot and activate. After the application restarts, when i click the firewall switch it just flashes on then off, no matter what settings I have it on.

When moving to the Ultimate key I would repeat all of the above steps. Typically I would run an additional firewall on top of Glasswire, but I’ve since completely removed that from my system just to be sure it doesn’t involve that. I’ve used this exact configuration for several years now without any problems until now.

Thanks :smiley:


#2

No Anti-Malware, or any other form of “Anti-Virus”


#3

@elitepad

I see you have already tried some clean installs, but could you try once again exactly like this?

  1. Go to add/remove programs and uninstall GlassWire. Do not use a third party uninstaller please.

  2. Go to your “Windows Firewall” control panel and choose “restore defaults”.

  3. Reboot - Important!!!

  4. Download GlassWire from www.glasswire.com and choose its “clean install” and “reset firewall” options in the installer.

  5. Go to the top left GlassWire menu and choose “activate” and paste in your code.

  6. Try to turn on the firewall now. If it still does not work please email us a screenshot with a link to this thread. We can then suggest how to turn on logging so we can see what’s happening.

https://www.glasswire.com/contact/


#4

It ended up being my Windows installation, I tried all of the above several times.
Thank the lord of PIXIE boot lol

Thanks for all of the help :smiley: