Strange issue, when blocking GW adds items in Win Firewall on c:\ as "s:\\\"?

So here’s the problem: whenever I choose to block a program, I noticed that anything on my primary drive was not being blocked.

I opened up Windows Firewall (Win7 64bit) and Glasswire has added a line to the Windows Firewall, but instead of “c:\program files (x86)\internet explorer\iexplore.exe” it blocks “s:\\program files (x86)\internet explorer\iexplore.exe”. Note the double \… strange. Is s:\\ a shortcut for the system drive that I’m unaware of?

And, in the above example, IE still works and connects just fine. Note that this doesn’t happen on any other drives; if I block an executable on my D drive, the blocking works and in Windows Firewall a line is added for blocking “d:\whatever.exe”.

Thx for the program, I hope I can make it work - I’m a big fan of simple and lightweight.

We just released an update this morning, can you install the update and reboot and check this problem again?

Please refer to my post on the same issue on GlassWire setting Path wrongly to Apps …

I hope it works out well for you …

Thank you


Please see below on my post on this PATH Set Wrongly issue :

Dear Glasswire,

I have downloaded the Latest Updated version of GlassWire and I still have the “Path Set Wrongly issue” …

I know why Glasswire is setting the Path to “i:”

Glasswire is setting the Path to i:\ because it is the First Windows partition in Disk 0

If I change the Drive Letter of the First Windows partition of Disk 0 to Z:\

Glasswire will now set all Application to point to “Z:\Program Files\App Folder”

This is the reason why I am getting all my apps in GlassWire pointing to “i:”

Because GlassWire is pointing all path to the First Windows Partition of Disk 0 …

So now that you know why GlassWire is doing this … can you please try to solve this issue for me as i really really need to use GlassWire ?

We hope to fix this problem with paths in our next release in the next 30 days. Meanwhile please contact our helpdesk if you’d like a refund.

The update did not resolve the issue. Blocked programs still on the primary drive are still listed as “s:\\whatever.exe” Again with the strange double \…

I also tried installing GW itself to the non-primary drive to see if that would have any effect, it did not. Same behavior, primary drive mappings are wrong all other drives are correct.

Some additional information on my system if it helps:

  • Dual boot Win7/Linux Mint 17.2, that loads into a grub menu.

  • 480GB ssd drive has 3 partitions, the 100mb system partition, primary
    ntfs formatted windows partition (the c:\ drive) and a 30gb partition
    for linux root that is visible in disk management as a healthy
    partition but is not directly accessible by windows (ext4 formatted)

  • Second drive is a typical HDD also with 3 partitions, all healthy
    primaries. The fist partitions is NTFS formatted for files used with windows,
    the second is a small swap partition for Linux and last a partition for the
    Linux \home directory. (Again partitions for linux are visible by disk
    management as healthy partitions but non-accessible ext4 formatted)

  • Both OSes are 64 bit

  • Basic hardware is i5-2500k OC @4.2GHz, AMD HD7950OC, 12GB ram

So I don’t know if this is a general problem, since One Above All seems to be having the same issue, or if this is as a result of my dual boot.

In either event this doesn’t appear to be something that should be difficult to fix in the code… but that could just be my ignorance on how the windows firewall interface works.

Hey Gar = Dual boot Win 7 /Linux Mint 17.2 ? exactly what I have didn’t know you could run it on LInux . I have a separate USB Samsung 250 GB drive on a hub running Linuxworks but no cache shown as Samsung SSD,s wont show it on USB only direct internally connected to SATA but will see if I can install it on Linux even your OC is the same as mine I know the 2500K nearly got it then the 3000 series came out and I got the 3770K . You CPU was very popular not long back.

I have solve this issue for my GlassWire Installation.

What you need to do is :smile:

  1. This Works for me with my Path Set Wrongly Issue with GlassWire
  2. I am using Windows 10 64Bit and it should be the same with the other Windows OS
  3. Open Windows Explorer >>> Right Click “This PC” and Select “Manage” >>> Click on “Disk Management”
  4. For ALL Disks that does not contain the “C:”, you need to >>> Right Click on the Disk # and select >>> “OFFLINE” >>> This is also known as “UnMount Disk” - What you are doing here is to set “ALL” Disk # to “OFFLINE”. The ONLY Disk # that is Online is the Disk # with C:\
  5. After you have “UnMounted” and Set “OFFLINE” all the Disks # that does not contain C:, you Install GlassWire onto C:\
  6. After GlassWire is Installed, you “UNDO” Step (4) by >>> Right Click on the Disk # and select >>> “ONLINE” Accordingly for all Disk #
  7. Reboot and GlassWire will now point all Application Path to C:\
  8. Now, in the “Click to Block” Window, all Application should default to C:\

I hope this help you solve your Path Set Wrongly issue …

It worked for me and I am now a VERY Happy User of GlassWire !!!



Win7 disk management doesn’t have an offline option, but I believe the equivalent would be to simply remove the drive letter, which unmounts the drive. Does anyone know for sure? I just don’t want to lose any data.

Also, at the GW dev team, even if One’s suggestion works this seems like an excessive step to have to take… no offense, but I don’t think that’s an unfair statement.


"run it on LInux" What’s the “it”? :smile: if you mean GW, i’m not… only on my windows installment, i was just letting the devs know I’m running a dual boot in case that causes some issue with their code.

Careful running a drive off a hub, especially a SSD, unless you’re sure both the computer connection and hub are 3.x you’ll be choking the life out of the drive and no matter the usb version the trim command may or may not work even with usb 3.x which is essential to the life of an ssd. Much better to use eSATA if possible.

Linux doesn’t technically require a swap drive, but its a really good idea. If you dont’ want it to hammer the swap file too much, which a typical install tends to do, you need to change the “swappiness”. On Ubuntu based installations that setting is in /etc/sysctl.conf, just as a reminder you’ll need to use sudo before your text editor since its under the root. For some reason vm.swappiness defaults to a very high 60, maybe this is from a time when people had a lot less ram in their systems, idk. I set it to 10 and and the swap file rarely gets touched.

  • as a side note if you drive partitions are maxed out you can shrink them using gparted on linux or disk management on windows. IMO, your swap drive doesn’t need to be more than a few GBs. I set mine to 8GB and I’ve never seen more than a hundred MB actually used. Granted I have 12GB of ram, your mileage may vary…

And yeah, my 2500k was purchased at launch. Honestly probably the best bang for the buck I’ve ever spent on any component ever. $210 for a cpu that OC’d on just air cooling for gaming outruns or matches any cpu out there except for the recently introduced 4790k. I like the i7’s and they certainly have an advantage on heavily multi-threaded processes, but I’m a gamer first and foremost and for those applications the difference between an i7 and i5 is de minimus. Never before have I had a cpu that 4.5 years later is still considered in the top tier for gaming… maybe that’s more of a comment on the lack of innovation in the cpu market and/or a comment on the pathetic support for multi-core/hyperthreading in the vast majority of games. :smile:

Anyone at glasswire want to respond to this? Is this really so hard to fix?

Should I just give a poor review on my download site of choice because your product is unusable, and worse yet falsely portrays that it is working, on any system that dares to mount more than one drive?

Do you understand what I’m saying to you?



Selling a product knowing it does not work? If you think your eula protects you from that, then perhaps you need to have a conversation with a competent attorney.

My computer has more than one drive mounted and I am unable to reproduce this issue. For me GlassWire works as normal, otherwise we would not have released it to the public. Please contact our helpdesk so we can give you an unreleased version to test so we can investigate and fix your problem.

Also please be sure you’re using our latest version of GlassWire that was released last week.

You already admitted in your prior post that you know you have a issue. You wrote:
“We hope to fix this problem with paths in our next release in the next 30 days.”

And your response is, it works on your personal computer, therefore the software is okay?

I also already informed you that I installed the new version. Its literally the first sentence in my response to your earlier post.

And to pre-answer any more boilerplate responses… Yes, I installed the version that came out yesterday. NO, it does not fix the problem.

Without being able to reproduce the issue it’s difficult to solve the problem. If you’d like to help us find and fix this issue please email our helpdesk so we can ask you to test a version that generates logs, then you can email us the logs if you feel comfortable doing so. Thanks.

Also we released yet another update today. Please try doing a completely clean install with our latest version by uninstalling GlassWire, then going to the “programdata” folder and deleting the “GlassWire” folder then rebooting and reinstalling our new version.

Gar as you sound like a tech. maybe you could try a MS app which might?or not help you locate the problem its called =DevCon Command LIne Utilty alternative to device manager this app is highly technical but I reckon you will know what to do. I checked and although its been out for many years it isnt publicised by MS for obvious reasons (meant for tech staff ) its available on their website in both 32 Bit and 64 Bit I am not saying its the answer but I have found in engineering a step at a time gets you there.