The GlassWire service stopped running 2020

Hi guys, checking the forums etc this seems to be a demon that keeps rearing its ugly head.

I’ve tried clean installing the app several times and after a certain amount of time after I’ve got it setup nicely - it just fails and no matter what I do from restarts etc it wont come back until I do another clean install … any ideas? :frowning:


Does this help? Maybe some of the services mentioned below are not running?

Why can’t GlassWire connect to its local server and why won’t GlassWire’s graph load?

GlassWire for Windows has a local Windows service that runs locally on your PC. This Windows service keeps track of your network activity for your PC or server. If that Windows service cannot start then GlassWire cannot graph your data usage.

Please note your graph data never leaves your PC, and we at GlassWire cannot ever access that data since it’s only stored locally on your own PC or server. Our privacy policy explains how we can’t ever see your data.

If you are experiencing this problem first try rebooting your PC. If GlassWire still cannot run please uninstall GlassWire in add/remove programs, then reboot your PC (this is an important step in the process), then reinstall GlassWire while checking its “clean install” option in its installer. You can download our latest software from our download page.

If GlassWire’s graph will still not load please check to see if the following Windows services are running in the Windows task manager:

  • WlanSvc (WLan AutoConfig)
  • BFE (Base Filtering Engine)
  • EventLog (Windows Event Log)

These Windows services are usually on by default unless you disabled them. If you find these services are running but GlassWire will still not run please consider running Windows Update. With very old versions of Windows GlassWire may not run properly. After updating your device please once again try a clean install with GlassWire in the order listed above.

Hi, No.

Before posting I already followed this guide and I’m now on my 3rd or 4th time of installing glasswire, for it to work for less than an hour and then stop.

Could you recreate the problem, then send us logs?

  • Stop the GlassWire service with the task manager under “services”.
  • Open the file: C:\ProgramData\GlassWire\service\glasswire.conf as administrator with Notepad.
  • Set parameter LogEnabled to “true” and save changes.
  • Start the GlassWire service again by right clicking under the task manager and services.

When the issue shows up again please send us the logs from C:\ProgramData\GlassWire\service\log as soon as the issue is reproduced.

Please be sure you’re using our most recent version and please be sure all the services listed above are running.


I contacted support - thanks