"The GlassWire service stopped running."

I’ve used GlassWire before and i just freshly reinstalled it (i uninstalled it about 6 months ago).
and i always keep getting this error "The GlassWire service has stopped working."
even after Rebooting and reinstalling and even checking Windows Firewall it still doesn’t work.

forgot to add, i’m using v1.2.73

don’t need to worry anymore.


Hi! I’m getting the same error and I don’t know how to fix it.
What did you do?

1 Like

@tab, rid you fix it or did the problem just go away?

I’m interested because this has been an ongoing problem - I’ve had it many times.

@Thales_Vilela, trom the look of past problems, you could:

  1. install the latest version if you don’t already have it
  2. uninstall, reboot and reinstall - you can clear all past data during the install.

FYI, here’s the history I looked at:

1 Like
  1. Open Services by typing services.msc in Run.
  2. Find GlassWire Control Service
  3. Double-Click on it.
  4. Click on Start.
  5. Voila! It’s Done.
    Hope it Helped!
1 Like