The Startup option


The startup option does does not work., I check the box ., next time i re-boot ., I have to start glass wire by hand ., it comes un-checked



This is not a common problem. Do you use any third party software that disables software that starts up on boot? Some utilities and antivirus software will do this without your permission.


no., no such programs i have . all my other ones startup without no issues


Have you done the latest Windows Creators update? Maybe that makes changes to the startup programs. What about cleaning software? Sometimes those applications can stop startup programs.

I recommend uninstalling GlassWire, rebooting, then reinstalling our latest version with the “clean” install option, then reboot again and you’ll see GlassWire should start up on its own (you don’t have to check anything in the settings).


i put glasswire on cores 1,2 and 3 ., leaving core 0 for window processes . and after i did glasswire started up upon boot now

close this


kindly explain in details how did u do that… i am facing smae problem as urs … but unable to understand how u put it in cores 1 …etc.



The cores thing shouldn’t make any difference about GlassWire starting up. Do you use any third party applications that stop other apps from starting up? If so try white listing GlassWire.


Glasswire , has a very high IO . if u have cpu cores ., you can remove glasswire on Core 0… ., freeing it up for the windows processes


Youtube can show you how cpu cores work


a clean install solved everything … thank you for your time thu