Trouble with Win11 Install

Having issues installing the latest version on a new Windows 11 machine. The installer gets to the same point and then just closes. No error message, it just disappears. I was able to grab a snip of the installer right before it exited:
Screenshot 2022-08-09 120609

I searched the registry for the Publisher listed in this message, found 2 entries and deleted them.

I noticed that in the Windows security log that the Windows Filtering Platform has been stopping gwinst.exe, which I assume refers to “glasswire install”.
Tried messing around to disable the filtering platform, and couldn’t find anything definitive.

Tried installing with the Windows firewall disabled.
Tried with and without “clean install” selected.

Not sure where to go from here…

Got it working. I did some searching on NET HELPMSG 2182, and it looked like it was potentially a problem with the Windows BITS Service.

I followed the steps here to repair:

and got a new error message while installing:
new error

This led me to just delete the Glasswire directory and retrying the install again with admin rights; probably wasn’t needed, but just wanted to be sure that there wasn’t any permission restrictions at play. This time it worked.

Ways to fix-
Make sure that your device has enough space.
Run Windows Update a few times.
Check third-party drivers and download any updates.
Unplug extra hardware.
Check Device Manager for errors.
Remove third-party security software.
Repair hard-drive errors.
Do a clean restart into Windows.

This may help you,
Rachel Gomez