Unable to install new version due to uninstall fail

As the title says, I am unable to install new version since the installer gets stuck on uninstalling the previous ver.

Please help.

This sounds funny but can you try rebooting, then reinstall GlassWire on top of itself? Now try again to uninstall in add/remove programs.

If that does not work can you go to your Windows Services in the task manager and kill our service?

Hi Ken,

tried that and got this:

I can’t seem to be able to uninstall or install on top at all. Also, how do I kill your service? I can only stop or start.

Kill all GlassWire processes from Processes tab page in your screenshot.

The only Glasswire process under processes is the installation process, which I have to kill everytime I start a new uninstall/install since it gets stuck (see my screenshots).


You tried a reboot, correct?

If you choose “clean install” when trying to reinstall does it make any difference? I know it sounds silly but sometimes if you reinstall GlassWire it will then solve any uninstall issues. Usually if that doesn’t solve it then killing our services will solve it, but I can see you tried that.

I will discuss some other options with our team, thanks and sorry for the issue.

Yes, same result.

Also tried “clean install”, same result.

The service is stopped by the uninstaller so I can only start it again, same result.

Let me know what you find out from the team, thanks.


Please terminate ALL these GlassWire components in the task manager.

Now reinstall GlassWire using its “clean install” option and let me know your results.

Ken, I’m sorry but I don’t have any of those 3 to terminate:


Some questions.

  1. C:\Program Files (x86)\GlassWire - Is GlassWire there and does it still exist on your PC?

  2. Since there are no running GlassWire instances and since GlassWire files can’t be removed, then there is something blocking the file removal. Is it possible that there is an AV software that blocks access to the GlassWire files?

  3. Are you able to remove GWCtlSrv.exe manually?

  4. Does Uninstall.exe exist in the GlassWire installation folder?

Maybe GlassWire is already uninstalled but you’re somehow able to run our uninstaller over and over.

  1. Yes:
  2. I run Norton 360 latest ver. I have had no similar problem before running Glasswire + Norton 360, the problem started just now. I have made no change in the setting for the AV and can find no setting to “block uninstall” or similar. Glasswire is allowed through the firewall.
  3. Yes.
  4. Yes.

Running GlassWireSetup.exe after removing GWCtlSrv.exe manually I get:

Should I perhaps run a separate uninstaller like “RevoUninstaller” to get rid of Glasswire, in order to install the new ver?

Please advise.


Have you used the RevoUninstaller previously? We have found third party uninstallers often cause these issues because they don’t delete our services most of the time.

I will ask our team for some other ideas. This is very weird.


Can you try to run the uninstall.exe from the GlassWire directory shown in 1 above?

Then please choose “show details” and copy the logs and send them to me as a private message here, or via email. https://www.glasswire.com/contact/

Did like you said and now I get:

I never ran any uninstaller like “RevoUninstaller” before, it was just a suggestion.

Also, I clicked the app in the taskbar and it says:

1 Like


Is there anything unusual about your Windows settings or setup? Do you use any unusual security software?

I will ask our team if they have some other ideas. With close to 20 million installs nobody has reported this so I am not sure what to suggest now.


GlassWire should always uninstall properly simply by going to add/remove programs in Windows. However it appears this is not working for you for some reason that we are unable to figure out.

We have just made this detailed guide just for you on how to uninstall GlassWire manually if our uninstaller fails somehow.

First quit the GlassWire application.
Next stop the GlassWire service from the Services tab of the Task Manager.

Check that there are no GlassWire processes left on the Details tab of the Task Manager.

Run cmd.exe as Administrator.
Open the GlassWire installation directory: cd “C:\Program Files (x86)\GlassWire”
Uninstall the GlassWire Service: GWCtlSrv.exe -u

Uninstall the GlassWire driver executing the following commands one by one:

%SystemRoot%\System32\net.exe stop gwdrv
%SystemRoot%\System32\RunDLL32.Exe SETUPAPI.DLL,InstallHinfSection DefaultUninstall 132 %SystemRoot%\System32\Drivers\gwdrv.inf
del %SystemRoot%\System32\Drivers\gwdrv.cat
del %SystemRoot%\System32\Drivers\gwdrv.inf
del %SystemRoot%\System32\Drivers\gwdrv.sys

Delete the GlassWire installation directory.

1 Like

Ken, sorry about all the hoopla. Uninstalled Comodo Free Firewall and lo and behold the Glasswire installer ran as before!

I never had this problem with Comodo before, that’s why I didn’t connect the dots. This was the last time I ever did I can tell you that.

Well, I guess you can add this to the Glasswire Knowledge Base for future reference. Comodo itself failed to remove itself, I had to resort to their " Uninstaller Tool" to get rd of it. It is located here: https://help.comodo.com/topic-72-1-766-12685-.html.

Again, I apologize for the waste of time and thank you and the team for all the help. First class!




Very weird! So you are saying GlassWire would not uninstall until you uninstalled Comodo? I don’t understand how it could matter. Our uninstaller shouldn’t have to connect to the network at all to operate.

Was our app quarantined somehow by Comodo?

We will see if we can recreate this. Thanks for posting the solution and I am glad everything is OK now.

Yes Sir, I was able to install GW once Comodo was gone.

As far as I know Glasswire was not added as quarantine in Comodo, at least I didn’t add it.

Let me know if I can assist you further in any way.

1 Like

Just a thought, Could it be that you’ve set some cranky options in your privacy settings that will prevent any app from making changes to your system folders?

If you look in the Settings > Privacy > App Permissions > File System Tab.
Is this disabled? Or have you set it to disallow apps from accessing it?
If anything, try to enable it and try again just to check. This has caused a lot of hairloss for people in the past.

It could be that Comodo has done that for you somehow.

1 Like