Updated from 2.2.258 to 2.2.260 - all settings gone


When I updated to version 2.2.258 the alarms and things were gone. With the fix I was able to bring this back again. Now with the update to 2.2.260 all data is gone again and the fix no longer works.


1 Like


Sorry for the issue. The issue is now solved if someone upgrades to our latest version from 2.2.241 but if you used 2.2.258 and upgraded to 2.2.260 it appears this issue can occur.

I will ask our team if there is another fix they can suggest for 2.2.258 to 2.2.260 upgraders.

@MiK, thanks for saving me from the possible hassle of another incomplete install.

I haven’t actually confirmed this is an issue, I am just guessing at this point. Hopefully I will know more Monday.

I edited my comment to reflect that it is not confirmed. But I will wait for a later version anyway.

1 Like

I had this issue as well. Upgraded from .258 to .260 on a headless server. Oddly the upgrade went fine on my own PC and always have.

i already lost all my settings just upgrading to 2.2.258

RIP firewall

I forgot and upgraded so all my data is gone … again. :cry:

How about providing us with a utility that merges old data files into the current version? That way the data in old files that have been aborted by the upgrade can be merged into the latest version so we can preserve a complete and continuous record of our network usage.


Do these instructions solve it? Thanks for your feedback on the utility idea.

No. I’d already tried that.

I’m very sorry this happened.

We put out a fix as quickly as we could (it’s now available) and we will take care to make sure this never happens again in the future.

That solves one part of the problem - thanks

The other part is that there is no remedy for the impact on my data. I now have a collection of disconnected GlassWire database files that contain my data for several years with no means to get them into one time series in the current database. Even when I fixed the 2.2.258 problem, I was still left with a gap in the data between when the problem occurred and when I copied back the database from the previous version.

I’m speaking bluntly but feeling sad that I should even have to say this. :cry:

I don’t need another sorry, I need a turnaround in Glasswire efforts to remedy the problems that you’ve created for us users. :pray:

What is the use of having unlimited history if it gets curtailed every year by Glasswire bugs so I’ve never managed to use that feature?

I’ve lost data or the entire database at least once a year for five years and you’ve never provided a remedy for any of the broken history. :wastebasket: :cry: There’s literally 100+ topics with lost history, not just usage but alerts too:

Your fixes only ever restore the ongoing functioning of Glasswire and always neglect to deal with the other impacts it has on us users. We are powerless to resolve this ourselves because you won’t provide a suitable feature/tool and you won’t provide the database format so a third-party product could be feasible. :expressionless:

Thanks for the detailed feedback.

If you are curious about the cause of this issue, it’s because of two things:

  1. We recently optimized our software to use less resources overall and this required a database conversion. Our QA tested carefully and I also tested carefully myself but some databases were corrupted for some reason. We’re still trying to recreate the issue so we can avoid it in the future, but it’s unlikely to happen again since we currently have no plans for further database optimizations.

  2. We recently released our “Lite” version. https://blog.glasswire.com/2020/10/06/introducing-glasswire-lite/ We wanted to protect the user’s history with Lite so we’d move it so it would be backed up. That way if a user used Lite then went back to our normal version the history would still be saved and intact with no issues. Unfortunately we unexpectedly introduced a bug that caused normal GlassWire users upgrading to move their history. We then quickly put out a fix, along with giving instructions on how to get any lost history back but unfortunately it does not seem to work in your situation.

We tested carefully with QA with both versions, and I myself updated from both versions but we somehow missed both these bugs. For the people who lost their history I agree it’s unacceptable and I apologize for the mistake. We will see if there is a way we can test with different scenarios in the future to avoid these types of issues going forward.

FYI, i updated 258 to 260 with lost of my settings but in contrast to
Mik, the fix worked.

It is interesting to know what caused upgrade failure. But that doesn’t address my concerns expressed in my previous post.

My post was asking whether you will remedy the actual problem GlassWire creates where my data is now in separate database files and cannot be merged together to give me one complete history. So far, you are providing no method to solve this problem…

In other words, you have only fixed the software; you haven’t repaired the damage done to our GlassWire history.

If my email app was supported like GlassWire then when an upgrade failed I would lose all my emails and have no means to restore them. The email app would be fixed and now be working correctly but there would be no remedy to get all my older emails into the current database.

Thankfully, my email app doesn’t work this way. It actually has the ability to import/export/merge databases which means I can collect all my data (the emails) together myself. That is something that GlassWire does not allow me to do.

I also said that these sort of problems are a recurring issue: at least once in each of the last five calendar years. My latest history was about 1.5 years old but it wasn’t continuous because there were at least two holes in the data where upgrades/bugs caused data loss each time I had to restore the database. One hole was most of a month where I hadn’t checked that my history was still recording and had to go to backup. The other gap was only a couple of hours where the upgrade failed.

1 Like

I will share these details with our team so we can improve. Perhaps an “export” option would help.

Thanks for your feedback and I apologize for the issue.