Version 2 not working here

Surprised no-one else has posted yet.

Glasswire Basic user, no real customisations … just set to ‘Ask to Connect’.

Installed new GW 2.0 over-the-top (restore Windows Firewall defaults unticked).

Could not access any websites. Also many settings are greyed out e.g. Firewall, ‘Ask to Connect’ drop-down, General Settings, etc.

Had to restore an image.

Win 10 Pro x64 v1709 16299.125. Could be it’s an interaction with other security softs like HitmanPro.Alert, but I got no messages, and never had this with v1.2.121, and prior.

Not so sure new interface is an an improvement either. Taskbar icon doesn’t resolve as nicely on my HD laptop.

Edit: Note that I have tried twice and reimaged back twice.


Sorry for the problem.

GlassWire 2.0 does not interact with other security software. In fact it interacts even less with the Windows Firewall and has the user’s firewall on by default.

I recommend reinstalling 2.0 with the “clean” install option in our installer, along with our “reset firewall” option. In this case GlassWire 2.0 has its firewall on by default with no rules and it cannot cause any problems with connections.

I will reimage and give that a try.

Hi Ken

That Worked. Maybe it’s worth warning that this may be necessary …

By ‘reset firewall’ option, I presumed you meant checking ‘restore windows firewall to default’?

I see my Firewall is set to OFF (grey) in the Firewall tab - should that be ON (green)?


I just made a new guide here for fixes. Upgrading to GlassWire 2.0, tips, tricks, bug reports, feedback, and fixes

The firewall can be off, unless you plan to block something and in that case it should be switched on. If it’s off then it does not access your Windows Firewall API at all and it keeps your system very clean.

Last question then: If I change to ‘Ask To Connect’ should the GW Firewall be on then? Or can it be off also?


The Firewall should be on to allow/deny connections.