Why is 1.1.46b GlassWire Control Service memory use bouncing up and down? (Solved)

This is not a problem for me, but I’ve noticed that memory usage for the GlassWire Control Service is bouncing. It sometimes doubles for a short period and then drops back to the long run average.

Here’s an example. A couple of days ago, with less than a week of data, GCS was using 35MB. When I checked two hours ago it was 99MB but soon dropped back so one hour ago it was 57MB, and now it is 44MB.

Is there some sort of consolidation of data or compression being performed?

I think it all depends on how many hosts are involved with the network activity. If you have heavy network activity with heavy host usage then GlassWire will temporarily use more memory to graph it, then as that time passes the data will be saved in the database and your memory should decrease.

When you saw higher memory usage were you using Bittorrent?

I don’t use torrents.

I have all the security settings turned on so I wondered if it is to do with “While you were away” because GlassWire is summarizing the network stats over most of a day?

I don’t think it has to do with “while you were away” but you can disable that feature in the settings to see. We actually made significantly more progress in limiting resource usage recently with the test versions so the next update should work much better for you.

The memory use does appear to build up while my computer is idle and starts dropping as soon as I start using it.

6.03 computer has been idle all night and memory usage has more than doubled.

It takes at least 15 seconds for the usage stats to appear.

6.04 In this case most of a minute as the timestamps show:

6.16 After about 15 minutes, memory used has dropped from 168 to 111 MB

6.33 After about half an hour, memory use has dropped by more than half.

6.47 After about three quarters of an hour, memory use has dropped by three quarters.

Do you have newer beta to test? Went back to 1.1.41b and this is from that version.


We will have a new version this week.

Great Thank You! :slightly_smiling:

This problem is resolved.

1 Like