Windows 10:Corrupted installer?

I cannot install vs.2.2.241 on vs.2.1. 0 Instead, I get message “Error decompressing data! Corrupted installer?”
How do I fix this?

@Rein_Helbs7

I have not seen this error reported yet. Could you try going to add/remove programs and uninstall GlassWire completely, then reboot, then re-download our latest installer and try launching it again?

https://www.glasswire.com/download/

I tried your recipe but it didn’t even try to do any installation work. It just showed a small screen with the error message reported before. I have a screen shot and will try to upload it for you.

@Rein_Helbs7

Would it be possible to download the file with a different web browser besides the one you used? Perhaps the file is getting corrupted somehow with that browser. I apologize for the issue. I have never seen this reported before so I am hoping it’s just a browser issue.

Hi Ken and Rein_Helbs7
I would also suggest to check the file hash after you download this GW exe file.
Hash # CC71998891158FF04157A052A9C419F8077AAFB57FB9D0310340277FCA8E6C5B

This way you know the file is as it should be and not corrupted.

Note: I got this hash from the changes page
https://www.glasswire.com/changes/

1 Like

It still doesn’t work. I got the Hash checker too now. — I got version 2.1.137 a few days before they came out with version.2.2.241 which is incompatible with that version because of some difference in the client/server. I think I have to wait for the version update that deals properly with that because I don’t know how to updae to that new client server model. Too bad that Glasswire didn’t get the update right to actually be a real update rather than a disconnected redesign. Can I somehow delete the current subscription with 350 days left and totally uninstall the current subscription. Then reactivate the subscription with the totally new client/server setup? I am disappointed!!

While I was signed in with the Rein_Helbs7 username, the glasswire system kept bugging me that supposedly I still hadn’t signed up. So I did with the username DrDisk07. Can I change my username so I only have ONE valid Glasswire Forum account?

Are you able to download any other installers and install software? For example can you download the Firefox installer?

  1. I can install Firefox and many others without problems. When I signed up for my current Glasswire Elite subscription on 31Aug2020 I ended up with version 2.1.173 with 357 days remaining as of today. A few days after, the new “update” to version 2.2.241 or so came out. However, it also warns that the new version is NOT compatible with the old one for some reason involving the client/server. So I better wait until the new version is compatible with the old one. Then it would really be an update and not a “changeover”.

  2. Somehow I am not being recognized as a forum member. It keeps reminding me to become a member. By now I have signed up TWICE (Rein_Helbs7 and DrDisk07) and still receive uploaded screen. I would like to just use one of the accounts anyway.

  3. I downloaded the new Glasswire 2.2.241 setup and ran the Hash checker on it. The result is
    d12ee1b1f9e00dd09ab0bd5d7b7474cf1454219628c7c06e86b2fedd0a81318a
    which may not be what was expected.

Anyway, thanks for help and commitment,
Reinhard Helbing

@Rein_Helbs7

I am going to send you a private message on the forum now to try something different (a different installer URL I set up for you). Please look for my message at the top right of the forum. Click the GlassWire icon, then click the small message icon that looks like an envelope.