Windows 8, Surface Pro 3 -- BSOD on GWDRV.SYS


I just had a system crash/memdump occur and Windows blamed it on GWDRV.SYS. This is a bit disconcerting…

I can provide the dump if needed.

We did not get a chance to test with a Surface yes. I’m sorry to hear about the crash. Please email to our bugs email address so we can fix this.

Ran into the same thing … app ran for about 5 minutes and then the blue screen due to gwdrv.sys.

Looks a great app though, so hopefully you can sort it through!

Rob, are you using a Surface also?

I ran into the same thing on Surface Pro 2. I had to do a System Restore, hope that fixed it.

I tried turning off Glasswire, disabling automatic startup, and rebooting. No matter what I did, opening Firefox and pressing “CTRL-T” resulted in a blue screen.

Same here. Original Surface Pro.

Seemed to run fine for awhile while I played with it, but then the original BSOD might have happened when computer went idle (not sure). Now, I get a BSOD before I can dismiss the initial Start Menu screen.

Going to try a system restore next.

We think we have figured this out and we hope to have an update out soon. Sorry about the problem.

Same issue here (surface pro2) but already on installation ! PAGE_FAULT_IN_NONPAGED_AREA (gwdrv.sys). Hope this updates will be out there soon.


Please update

Hi Guys,

FYI, I am using the last version 1.0.23 beta and I have got the same issue : PAGE_FAULT_IN_NONPAGED_AREA (gwdrv.sys).

(Awesome work guys though !, Hope you will get through this bug soon.)

Surface Pro 2

1 Like

Please try this just released update

Same issue on Surface Pro 2 running 1.0.25 beta. Was working fine with Bluetooth tethering to my phone for internet and also fine when not on a network at all but when connected to WiFi as soon as the PC starts up into Windows it gives the BSOD, resets and repeats until I get out of WiFi range or uninstall.

1 Like

Downloaded latest version (1.0.25b) this morning hoping for the best, but within 20 minutes I had same BSOD as mentioned when I started this thread. Will try again with the next release.

Sorry to hear the bug still exists. We will have an update out soon that you can try again. Thanks for your patience.

I’m getting this BSOD attributed to gwdrv.sys (paged fault in nonpaged area - gwdrv.sys) on a regular Windows 8.1 Pro laptop (no RT) every time I launch a USB tethering program. Need fix. Have to uninstall Glasswire until its available.

@jwm4 Can you send us a crash dump? Please go to C:\Windows\minidump and email it to our “bugs” email address at

Thanks for your help so we can fix this!

I’m getting this BSOD(paged fault in nonpaged area - gwdrv.sys) After I installed Avast 2015.
Using GlassWire(1.0.25 beta) in Windows 8.1.


Please try the new GlassWire version we just released this morning

Tried with the latest version and as soon as the install finished BSOD (paged fault in nonpaged area - gwdrv.sys) :frowning:
When my surface booted back up GlassWire didn’t load, the uninstall wasn’t in the list of programs in Control Panel and running it manually from the GlassWire folder didn’t work so not sure if the installation was able to fully complete before the BSOD. I’ve emailed the minidump to the bugs address.

Did the previous version work OK?